[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Installing Veracrypt

Hello everyone,
Below is a cross post from the Qubes forum where I haven’t had anybody offer any advice. I am not sure just which forum it should be on, so here it is. Apologies for the cross pot.

Hello everyone,
I have been driven mad this afternoon trying to install Veracrypt (VC) in whonix.

I’ll try to remember all that I have done. Which is plenty.

I have managed initially to install VC into my debian template and thence its vms with no problem. I did this by simply using gdebi. No problems.
Now it gets hard.

Before trying to install into my whonix-ws template I created a clone of my anon-whonix vm and have buggered around in successive clones trying to make this happen before I tinkered with my whonix template.
Using the above debian method, gdebi will run, but there is nothing installed.
So I have tried downloading the installer (tar.bz2) and the deb package and installing by not using gdebi. No luck.

I am aware of this post: Installing Veracrypt For qubes-whonix and I installed the dependency like so:

sudo apt install libwxgtk3.0-gtk3-dev

No luck. But if I type veracrypt in the terminal VC after these install attempts VC will launch. But it doesn’t appear in the qube settings. And it disappears if the VM is shutdown and then restarted.

I found another suggestion that I need to run the installation in xterm which I did with no luck.

It appears that this error message below that I consistently get may be at the heart of the matter:

user@host:~/QubesIncoming/Browsing-Clearnet$ ./veracrypt-1.25.9-setup-gui-x64
Verifying archive integrity...  100%   All good.
Uncompressing VeraCrypt 1.25.9 Installer  100%  
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
xterm: cannot load font "-misc-fixed-medium-r-semicondensed--13-120-75-75-c-60-iso10646-1"

I found another suggestion in a red hat forum with these workarounds:

Workaround 1:
Use a different locale
LANG=C xload

Workaround 2:
Edit /usr/share/X11/locale/en_US.UTF-8/XLC_LOCALE and comment out
fs6 {
charset {
name KOI8-R:GR
}
font {
primary KOI8-R:GR
}
}

This didn’t work.

I am pretty much searched out with this. I really haven’t got a clue what to do.

Everything is up to date etc.

I have used whonix plenty but in virtualbox exclusively. I am only now starting to use whonix in the qubes setting and I have had no problem installing VC before. I have managed to configure everything else in whonix so far that I wanted such as bleachbit, nitrokey etc without a hitch.

In my tiredness am I missing something obvious? Anybody got any tips that may help me?

Thanks for reading. I hope that I have covered all of what I have tried. I think so.

Love linux.

For Qubes-Whonix 16, you want this this package: veracrypt-1.25.9-Debian-11-amd64.deb. Download and perform verification checks as usual in a disposable vm. Qvm-copy the deb installer to your whonix-ws-16 template.

Open a terminal in the same folder you copied the deb installer:
sudo apt update
sudo dpkg -i veracrypt-1.25.9-Debian-11-amd64.deb
sudo apt --fix-broken install

Thank you very much for posting this. I am still struggling with this but gave up.

I’ll try this on the weekend and get back to the forum. Once again, thank you!

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]