install chromium

Hello, how to install a browser chromium.

sudo apt-get install chromium-browser chromium-browser-l10n - this comand does not work

this browser do I need in order to install the messenger Signal. I read your article about the conversation. But I want to use this messenger , especially qubes os and snoyden I recommend it. What is your personal opinion about this messenger?

Good day,

Well, our personal opionion has already been made clear in the thread you wrote you already read, here: Client-Server Instant Messengers (IM) Oct 2016

There are simply a few things surrounding it which make the whole thing seem like something which shouldn’t be recommended.

For installing Chromium, using

apt-get install chromium

should suffice.

Regarding Snowden, it is important to note that what he said about Signal/Open Whisper Systems is that they make very user friendly programs giving access to more people. He didn’t comment on their general safety.

Have a nice day,


1 Like

Generally we recommend to stay away from browsers other than Tor Browser. Details:

thanks for the answer! Can I install a tor browser translator and adblock? and how to make so that the tor to remember passwords?

Good day,

Isn’t to be recommended, as it can lead to changes in the fingerprint your browser has, thus making you less anonymous.

Have a nice day,


1 Like

good afternoon. Your help is not assessable !!! thank you for your work! I have a question. I use qubes-whonix, as a change in the debian-9 language?

Debian 9 will not be released as stable until Spring/Summer 2017. Once it is stable, Whonix & Qubes will release templates based on it.

1 Like

I need to update the whonix 13 in whonix 14, or not?

Once released, you should.

Good day, I use MAT program, but this program does not see jpg format. Which format converter, you can consult for whonyx-ws?

There are many reasons not to use Chrome/Chromium over Tor.

As already pointed out, you will be easily fingerprinted. How many people use Chromium over Tor and with unique addons? The answer is a small subset.

Secondly, forcing Chromium to fetch content outside of the Tor proxy is apparently trivial. See here:

Finally, the Tor Project have themselves outlined numerous chromium bugs that means low-grade, privacy-by-design is currently impossible. Ignore their advice at your peril.

This includes (information is a little dated, but many concerns no doubt still apply):

  • Proxy by-pass bugs allowing the direct bypass of incognito mode proxy settings;
  • Browser state leak bugs leading to change from incognito mode to regular browser setting;
  • Numerous third party identifiers; and
  • Numerous fingerprinting issues that can’t be easily solved.


So, while Chrome/Chromium might have better sandboxing currently - which will be solved by Firefox in the next 3 or 4 releases anyway - your privacy will simply be blown out of the water i.e. you might as well raise a red flag to any network adversaries looking to track you.

With respect to MAT and jpeg, MAT states that the currently supported formats include that and more:


Portable Network Graphics (.png)
JPEG (.jpg, .jpeg, …)
TIFF (.tif, tiff, …)
Open Documents (.odt, .odx, .ods, …)
Office OpenXml (.docx, .pptx, .xlsx, …)
Portable Document Fileformat (.pdf)
Tape ARchives (.tar, .tar.bz2, …)
MPEG AUdio (.mp3, .mp2, .mp1, …)
Ogg Vorbis (.ogg, …)
Free Lossless Audio Codec (.flac)
Torrent (.torrent)

But note warnings (also, not currently being supported by author for health reasons):

Why MAT is not the ultimate solution?

Mat only removes metadata from your files, it does not anonymise their content, nor handle watermarking, steganography, or any overly customized metadata field/system. Also please not that MAT does its best to scrub as much metadata as possible, it’s not really efficient at scrubbing embedded media inside complex formats. For examples, images embedded inside PDF may not be cleaned!

Other tools that may be of interest:

  • Exiftool, a Perl application for editing metadata in a wide variety of files.
  • exiv2, a C++ application to manage image metadata
  • jhead, a jpeg header manipulation tool
  • pdfparanoia, a tool to remove watermark from academic papers

Could we amend the

page with with that info?

//cc @HulaHoop

Debian maintainers removed PDF support in most recent MAT update for this reason. (changelog is broken: http://ftp-master.metadata.debian.org/changelogs//main/m/mat/mat_0.5.2-3+deb8u1_changelog)

1 Like


1 Like

Hello I need to use Chromium within my Whonix Workstation.
I know it’s better to use Tor Browser for better privacy, but I need to use
sites which requires Chrome/Chromium.
I managed to install the browser, but it doesn’t work meaning it launches correctly but it doesn’t allow me to surf the web.
I tried to launch the browser from the command line in order to get some error and I get this:

[2821:2821:0610/124255.327247:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[2829:10:0610/124255.377861:ERROR:command_buffer_proxy_impl.cc(125)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.
Fontconfig error: Cannot load default config file

Looking for Internet for this error message I found out that this can be solved by setting


I put this environment variable in the environment file and reboot the system. It had no effect whatsoever.
I tried to open all of the tcp ports as well in the firewall in order to check if the problem was there but it didn’t have any effect as well.
Can someone tell me what’s the deal with this weird error?

Are you using the one packaged in Debian or from their repo?

chromium from Debian package sources should work out of the box indeed.

sudo apt update

sudo apt install chromium

darkomega via Whonix Forum:

I know it’s better to use Tor Browser for better privacy, but I need to use
sites which requires Chrome/Chromium.

For the sake of not creating a labyrinth which nobody will be able to
master in future, please:

  • no: pile up workarounds
  • yes: fix root issues

Works for me either with

apt install chromium

or (newer version):

wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
apt install ./google-chrome-stable_current_amd64.deb

I tried both ways and they didn’t work either lol…
Apt method was the way I used in order to install the program.
I tried with dpkm too but the program didn’t even launch because of weird errors.
Is it possible it’s something related to the virtual gpu within virtual box or an apparmor issue?

I don’t know - does it work on a freshly installed workstation?

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]