[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

I2P Integration


#89

Tried that however the documentation is non existent and going by the instructions of someone who dug it out on his own, it seems broken.

This should be more foolproof


#90

I think it won’t hurt to use the blacklist feature (if it works ) https://www.privoxy.org/user-manual/actions-file.html#BLOCK

Requests for URLs to which this action applies are blocked, i.e. the requests are trapped by Privoxy and the requested URL is never retrieved, but is answered locally with a substitute page or image, as determined by the handle-as-image, set-image-blocker, and handle-as-empty-document actions.

If i understand this correct it would enable us to give the user a hint that he should use the standart TBB for clearnet sites

Going to test this later


#91

For this I suggest shipping another custom homepage for this TBB instance, that explains it won’t connect to the clearnet for privacy reasons. The page would have the Whonix ASCII but none of the other clearnet links. Something along the line of “Attention: This browser is configured to connect to local proxies only. Please check bookmarks for possible destinations. Make sure you have installed/enabled the corresponding software”

Ticket: https://phabricator.whonix.org/T795

@iry it would be awesome if you could throw together this page whenever you have time :slight_smile:


#92

great job , going to test these steps now. but i have some comments:

why r u using the non-https repos of i2p ?

also splitting steps for Template and Appvm leading to horrible results of modifications. u need to make these only inside the Templates as that will ease the creation of “Standalone VMs” from the templates. but working on these steps is eliminating this possibility to get a complete standalone VM based on whonix-i2p.

  • Commands that needs to be fixed in order to make things work:



#93

Sure, but i think it would also be helpful to redirect the user to said warning if he mistakes the localonlyTBB with the stock one and tries to access clearnet sites, it would certainly be better than an error message from a failed connection attempt.

@TNT_BOM_BOM

Yeah it’s a bit hacked together, going to fix that soon

fixed, good call

New command for the Repo (cant edit top Post atm)

echo -e ‘deb https://deb.i2p2.de/ stretch main\ndeb-src https://deb.i2p2.de/ stretch main’ | sudo tee /etc/apt/sources.list.d/i2p-release.list > /dev/null

echo -e ‘deb https://deb.i2p2.de/ jessie main\ndeb-src https://deb.i2p2.de/ jessie main’ | sudo tee /etc/apt/sources.list.d/i2p-release.list > /dev/null

please test again


#94

Updated top Post


#95

trusted.gpg.d still a big issue because u cant install i2p after doing that step.

check this website for separated packages of i2p:

skank.i2p


#96

Just be careful with it. I pulled a bunch of disparate pieces from other projects together and disabled a couple of things. I just re-enabled TorButton, for instance, I don’t know if it might cause any kind of trouble by connecting(accidentally?) to an available Tor Control Port on a configuration where it’s enabled. I don’t yet know how to keep it from doing so or even if it would be an issue. I think it would be best, for now, if I found a way to disable to communication with the control port while leaving the rest of the functionality intact, and I am looking into what TorButton does with the control port to see if it would be worth trying to implement something compatible with TorButton in si-i2p-plugin. No matter what though, Javascript is not my strong suit and I’m very busy this week, it may take me a few days to get the control port disabled and I really don’t know what TorButton does with the control port yet.

Edit: I must have missed your other post the first time I read through the thread. I’m going to revert the change I just made for now but it seemed to be working when I tried it with TorButton added back in before. Could it have been tor-launcher instead? I kind of hope so, I’m reading through the TorButton spec and I’d really like to be able to make them work together without issues. I’m working on it right now.


#97

Yes there is definitely a key problem from the instructions.

I keep getting the issue of an untrusted public key not found after the instructions of:

To import asc key files into trusted.gpg.d they must be converted into a .gpg keychain file first.

user@host:~$ gpg --no-default-keyring --keyring ./i2p-pubkey.gpg --import i2p-debian-repo.key.asc

So I tried to instead install the deb packages… the i2p-keyring, privoxy, killyourtv-keyring and i2prouter… no such luck…


#98

No worries, @HulaHoop found the Problem :


#99

Yes, i’ll try to fix this asap, but i’m unable to test atm because i’m in hospital for the next days :frowning:

You could use apt-key add after verifiyng the key (not recommended though)


#100

@goldstein-otg I hope everything is OK. Get well soon.


#101

That’s a relief. I’ve added the missing configuration options to my builds and made sure they work with 7.5.4. I’m also switching to making the tar.gz’s and deb’s available as releases rather than keeping them in the repository, and there’s a privoxy version which is the same as the others, but configured to use localhost:8118.


#102

Thanks, i’ll try my best to be back asap and fix the remaining issues.

Edit:
I’m back, give me a couple of hours to be back on track…


Whonix experimental for how long
#103

A couple of Questions:

it downloads a configuration file from PurpleI2P: https://github.com/PurpleI2P/i2pdbrowser/raw/master/linux/build/preferences/syspref.js and sets it as the profile preferences in the TorBrowser instead.

Why do you replace the syspref.js ? AFAIK this is only useful to stock Firefox and not TBB, i guess this would create a unique Fingerprint

It also adds a line to keep your i2p use from being detectable requests for resources on your i2p router’s administration page.

Could you please point me to that line ?

Do you plan on maintaining it for a while (if smth breaks) ?


#104

@HulaHoop I’m unable to edit the first Post ,the Edit button is completely missing, i can edit other Posts though, is there a limit to how often one can edit a Post ?
Edit:
I can edit almost every post except the ones before 23 March… i guess this has something to do with discourse settings? @Patrick
How can i edit the top Post now ?


#105

@0brand @entr0py is there any way you could make my top post editable again ?


#106

Nothing I can do my side to let you edit unfortunately. It may be a server side option. However if you are a mod you should be able to edit it whenever you want. @Patrick can you promote Goldstein please?


#107

I would suggest: post the desired new top post as a comment in this
thread and then ask a moderator to replace the top post with your new
content.


#108

I rather create a Git repo and change it there,it would be a waste of time for both sides and the thread would get unnecessarily longer because of small fixes and error.