[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

I2P Integration

excellent , thx alot for that study.

although it shouldnt be through TBB only , if its possible for you can you compare the results of a clearnet browser like Firefox or any garbage browser like chrome or IE?

because when you do the test , it should benefit what I2P recommending now as they telling in their instructions to use those browsers. not just what you recommending to use (modified TBB).

1 Like

I actually wrote that documentation under their instruction, the browser recommendation is in the process of being updated, that is likely to comprise part of it. I’ve got a couple important things to squeeze into that process this week, hope to make some serious headway tomorrow.

I’ve got to finish a couple things with the fingerprinter, I kind of left it off mid-feature and need to fix it but work has been very busy, but once I fix it I will be continuously doing this and updating the fingerprint screenshot for at least a handful of browsers in default and modified configurations. I have tried it with a hardened non-tor Firefox already using this https://github.com/eyedeekay/firefox.profile.i2p, but now that I’ve actually run a current Tor Browser on a Windows machine and know it has a path I can fetch with an environment variable, that may change to Tor Browser as well pending some discussion. There was some friction shipping an alternate Firefox profile at first. I’ll also be doing probably at least vanilla Firefox, Vanilla Chrome, and either ungoogled-chromium or Brave as well.

On another topic, if we want out-of-router i2p applications, neither disabling the default ones nor writing new ones is terribly difficult. I’ve got a considerable amount of time in it already actually.

3 Likes
cd "$HOME/.i2pb/i2p-browser/Browser/" || exit 1

Non-ideal since in failure case would exit 1 without error message.

Is this even required? If that was to fail, it would be handled by proper error handling by /usr/bin/torbrowser anyhow? Could you remove please and test?

2 Likes

I think you’re right, and I think that this might be better link to diff. The top one is actually essential because in the non-presence of the browser it will still attempt to copy all those files into the non-existent folders.

2 Likes
1 Like

No connection to irc what so ever:

For IRC over i2p, the following seems to work:

  1. Open HexChat
  2. server/port := 127.0.0.1/6668
  3. Disable proxy server: Settings > Preferences > Network Setup > Proxy Server > Type = (Disabled)
1 Like

yes true , but it needs to be disabled by default in Whonix-I2P-Template (when there will be separated builds)

Just leaving that here. Never seen before. Perhaps useful for something.

2 Likes

@TNT_BOM_BOM @goldstein-otg I don’t know if anyone has brought i2p-zero to your attention yet, but it might be a way to rely on a simplified java-i2p router without a web interface. Also in the next few months java-i2p should be getting an /etc/i2p.d/-like(Name not settled AFAIK) folder for configuration.

2 Likes

@eyedeekay its developed from monero developers. its good one , but until it becomes stable and uploaded to debian repo it will take ages.

This looks like a great opportunity for collaboration:

2 Likes

I2Pd now added as debian package:

https://packages.debian.org/buster/i2pd

cc @goldstein-otg

2 Likes

i have tested i2pd and tried to see how its working. not a good alternative yet for i2p-java, needs much more years of work to achieve that.

I watched the whole kovri drama and the result (i2p-zero) and i have to agree with @TNT_BOM_BOM

This would be great :slight_smile:

This is great news, this makes it easier when whonix 15 is ready

I would like to know the reason why you say that ?
I’ve had a short test and the only issue i could see (in a whonix setup) is the missing proxy option in i2pd to reseed , i had no issue on normal debian servers, one router ran over 2 month without an issue.

Thanks for keeping me in the loop :slight_smile:

2 Likes

some stuff i dont like to see when running a software:

  • It doesnt run under userspace by default , it needs root privileges to load though you have installed it from debian repo. ( sudo systemctl start i2pd.service not really ideal)

  • Its possible to run 2 apps instances just because you run it twice , which something nasty to have:

  • doesnt run after booting , you need to run it manually:
  • no checksum hashes for the downloaded provided until now (poor security interest)

…etc so no , its not really ready/stable as I2P-java.

(though its possible to be installed and run side by side with i2p-java)

Anytime, Glad that you still around :wink:

1 Like

@goldstein-otg your github account deleted ? if so please update if there is a new one.

Here you go:
https://bitbucket.org/mutedagain/whonix-i2p-guide/src/master/

Don’t expect anything from me in the near future, got other stuff to worry about.

Until then Goodbye…

1 Like

Bitbucket is acting retarded on archive sites so I used pastebin

https://pastebin.com/raw/bLg2ArZn

1 Like

I see , well good luck with life thanks for all your time and effort here.

Better to use:

https://privatebin.net/

to avoid cloudflare captcha

You can just use archive.org and not worry about CAPTCHAs :wink: