[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

I want to use Chromium within Whonix

Hello I need to use Chromium within my Whonix Workstation.
I know it’s better to use Tor Browser for better privacy, but I need to use
sites which requires Chrome/Chromium.
I managed to install the browser, but it doesn’t work meaning it launches correctly but it doesn’t allow me to surf the web.
I tried to launch the browser from the command line in order to get some error and I get this:

[2821:2821:0610/124255.327247:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process.
[2829:10:0610/124255.377861:ERROR:command_buffer_proxy_impl.cc(125)] ContextResult::kTransientFailure: Failed to send GpuChannelMsg_CreateCommandBuffer.
Fontconfig error: Cannot load default config file

Looking for Internet for this error message I found out that this can be solved by setting

MESA_GLSL_CACHE_DISABLE=true

I put this environment variable in the environment file and reboot the system. It had no effect whatsoever.
I tried to open all of the tcp ports as well in the firewall in order to check if the problem was there but it didn’t have any effect as well.
Can someone tell me what’s the deal with this weird error?

Are you using the one packaged in Debian or from their repo?

chromium from Debian package sources should work out of the box indeed.

sudo apt update

sudo apt install chromium

darkomega via Whonix Forum:

I know it’s better to use Tor Browser for better privacy, but I need to use
sites which requires Chrome/Chromium.

For the sake of not creating a labyrinth which nobody will be able to
master in future, please:

  • no: pile up workarounds
  • yes: fix root issues

Works for me either with

apt install chromium

or (newer version):

wget https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
apt install ./google-chrome-stable_current_amd64.deb

I tried both ways and they didn’t work either lol…
Apt method was the way I used in order to install the program.
I tried with dpkm too but the program didn’t even launch because of weird errors.
Is it possible it’s something related to the virtual gpu within virtual box or an apparmor issue?

I don’t know - does it work on a freshly installed workstation?

Here’s your problem and the workaround for it. You will have to diable mesa driver use by Chromium to get it working sandboxed until the bug is fixed.

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=918433

1 Like

I’ve already tried this fix, I’ve written it in my first post…

Please report to Debian, they can help troubleshoot and fix it more than we can.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]