[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

[Help Welcome] KVM Development - staying the course

Try drop on issues like previous.

What error?

Timeout file too big?

Timeout password entry taking too long while unattended?

Not sure yet. Haven’t seen the error. The script just runs the command for convince. Same should happen on manual execution. Should be possible to copy/paste same command. What’s wrong with the command? Ask upstream?

Yes.

This command I quoted unrecognized by gpg-agent and cripples any gpg operations.

Can’t work since that config file looks obviously invalid.

cat ~/.gnupg/gpg-agent.conf

“pinentry-qt /usr/bin/pinentrynno-grabndefault-cache-ttl 7200”

Shouldn’t use sudo since file location in user owned location. Best to delete ~/.gnupg/gpg-agent.conf and recreate with proper permissions and owned by user.

1 Like

Used this with same consequences Turns out you can ignore the cache completely and go ahead with the signing. Will drop the sudo and start again:

echo -e “pinentry-program /usr/bin/pinentry-qt\nno-grab\nignore-cache-for-signing\nmax-cache-ttl 7200” | sudo tee ~/.gnupg/gpg-agent.conf

Anyway I ran the most simplified version of the signing command manually in attempt to forget about the prepare release script. Ended up timing out. There must be something else screwing this up:

user@host:~/whonix_binary$ gpg --detach-sign --armor *.libvirt.xz
gpg: signing failed: Timeout
gpg: signing failed: Timeout

1 Like

Done at last. Uploaded. Up and running on my end with all the wiki instructions tested and working.

I ended up pressing ‘c’ to override the errors and it worked, signing everything and producing valid sigs.

The command for gpg-agent for reference though I’m not sue it helped is:

echo -e “pinentry-program /usr/bin/pinentry-qt\nno-grab\nignore-cache-for-signing\nmax-cache-ttl 7200\npinentry-timeout 86400” | tee ~/.gnupg/gpg-agent.conf

You might want to add signify-openbsd as a build dep for the dev guide if you haven’t already.


So far so good. Beautiful theme. I like how users are advised to select highest sec on TBB first run. Amazing stuff. Will put out a new release notice at some point today.

1 Like

sudo or not.
The usage of \n (which is included in that command) does not work.

Please look at the resulting configuration file and check if it looks as intended. It doesn’t.

1 Like

The forum software is formatting my quotes into the italic type that would indeed not give proper formatting but the ones I used on my end were the normal ones.

1 Like

Please use code tags for code, not quote. Like this:

```
code
```

1 Like

Note: https://www.whonix.org/w/index.php?title=Dev%2FBuild_Documentation%2F15_full&type=revision&diff=51000&oldid=50915

1 Like




1 Like

Fixed:

Mistake with video setting in GW, kicksecure and custom WS prevents them form starting.

Removed rombar off because having it enabled for more than 1 NIC caused the GW to freak out





Question: Are we already providing Kicksecure releases?

I’ll do another build once accepted since 15.0.0.6.8 includes these problems. I don’t see the point of linking to that build now.

Life would be easier if users actually bothered testing these things and reported back…

A post was merged into an existing topic: AppArmor for Complete System - Including init, PID1, Systemd, Everything! - Full System MAC policy

Merged.

Yes.

3 posts were merged into an existing topic: use sudoedit in Whonix documentation and Whonix software

https://www.whonix.org/wiki/File:Kvmbanner-logo26.png

https://www.whonix.org/w/index.php?title=KVM&type=revision&diff=52181&oldid=51935

1 Like

@Patrick just noticed xpdf silently fails to run when trying to open a pdf in 15.0.0.6.6

can you reproduce that? Any logs needed?

Scratch that, the file is malformed

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]