[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

GDebi Package Installer doesn't work in Whonix 15. Is there a fix?

I’m setting up my Whonix 15 for the first time, and GDebi (as GUI) cannot install .deb files. It simply closes off after I click ‘Install Package’.

This is a major problem for Whonix adoption. If users can’t easily install DEB files, then Whonix is way less usable. I’m sure most agree here that Whonix isn’t intended for developers only.

I’ve investigated and this appears to be caused by gksudo being removed in Buster onwards (related to moving to Wayland). The gdebi package moved to using policykit (the replacement method), but I’m thinking XFCE 4.12 may not have the code to make use of GDebi’s policykit implementation.

Does anyone know a solution for this?

I agree in principle.

However it doesn’t work that way.

Please review these two pages:

https://www.whonix.org/wiki/Support#Free_Support_Principle

Since this is a Debian / upstream issue.

In other words, please contribute, work with upstream to fix this.

Why not just run dpkg -i package.deb in a terminal instead?

dpkg doesn’t handle package dependencies automatically like gdebi does (or gdebi-gtk, the even easier GUI based on it, which is what we really want).

I’m continuing to investigate, and may update here once I have found a good enough solution. I’ve thought of one or two ideas…

And yeah @Patrick, this is not a Whonix problem, it’s a Buster + XFCE problem… (or put another way, it’s Whonix’s problem, but not Whonix’s fault.)

A post was split to a new topic: cannot use pkexec

A post was split to a new topic: cannot use gparted

Could you please report this upstream?

Indeed same cause as cannot use pkexec.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]