[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Gateway can't connect to Tor -- keep getting error message

The gateway I’ve been using won’t connect to Tor. I decided to import the ova all over again and start from scratch (and use a brand new gateway), and the brand new gateway has the same error message as the old gateway. This is the error message I keep getting:

[ERROR] [whonixcheck] check network interfaces Result: network interface eth0 not up!

Recommendation:
Try to manually start Whonix networking

sudo systemctl restart networking

Or reboot.

Debugging information:
Command cat /sys/class/net/eth0/carrier failed

I don’t know what any of this means, and I don’t know why it keeps appearing, even when I use a brand new (newly-imported) gateway that has never been used before. I can’t figure out how to connect to Tor on any gateway. I’ve tried for hours to connect and I always get this error message.

In addition, I have been getting the following error message:

[ERROR] [whonixcheck] Tor Connection Result:
Tor’s Control Port could not be reached!

Please report this Whonix bug!

(Technical information:)
(tor_circuit-established_check_exit_code: 277)
(tor_bootstrap_timeout_type: none)
(tor_bootstrap_status: NOTICE BOOTSTRAP PROGRESS=100 TAG=done SUMMARY=“Done”)
(check_socks_port_open_test: 22)
(Tor Circuit: not established)

I checked my Internet connection, and it is working (i.e. I can access the Internet on a regular non-Whonix browser).

Rebooting the gateway doesn’t seem to work – I turn it off and then on, it loads, runs whonixcheck, then gives the above two error messages.

Host operating system?

VirtualBox?

Did you change any settings during VM import? I suspect either that or VirtualBox installation broken.

Can you make Debian buster work in a VM?

I just got the Gateway to connect to Tor – I don’t know how I did it, but now it’s working. It may have had something to do with my Internet connection.

I use VirtualBox and the host I use is a Mac. I did not change any VM settings during import. I guess the problem was just some kind of bug in the system, or it was a connection problem.

This means the (virtual) machine did not have a (virtual) network interface.

sudo ifconfig

would show that too.

That can only happen when VirtualBox settings removed the virtual network interface or due to some VirtualBox (installation) bug.

This cannot happen

  • if just the host network connection is down.
  • even a host without a network interface would not cause this.
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]