[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Gateway apt dist-upgrade hangs on update Build initial module - Solution in Post Number 2

today i update my whonix Whonix-XFCE-15 gateway.
Now it hangs on: Build initial module for 4.19.0-8-amd64

After a restart i have tried: sudo dpkg --configure -a
but it hangs on Build initial module for 4.19.0-8-amd64 also.

i have waited about 15 minutes and nothing happens.

What can i do to fix it?

1 Like

Generally:

It is absolutely crucial to subscribe to and read the latest Whonix news category ‘important-news’ to stay in touch with ongoing developments. This way users benefit from notifications concerning important security vulnerabilities, potential upgrade issues and improved releases which address identified issues, like those affecting the updater or other core elements.

Specifically:

3 Likes

Thank you.

Hi friends, after a few days I tried to update my whonix gateway and when I type “sudo apt-get dist-upgrade” the update, the console freezes.

I tried to restart the gateway and give the command: sudo dpkg --configure -a. Unfortunately, the result does not change.

1 Like

Thanks I managed to solve the problem.

1 Like

Upon starting up both machines, it’s all smooth. Once inside them, things get a little bit slower. Problem started when tried to upgrade the distro and the gateway became unresponsive after downloading all updates.

Could this be due to a slower drive running at 5400 rpm?

Screen Capture:
i[dot]ibb[dot]co/0hBkHdy/IMG-065.png

1 Like

Dear WhoZero - Same Problem like you!

ef86

Don’t forget to read the solution in post 2 in this forum thread: Gateway apt dist-upgrade hangs on update Build initial module

1 Like

Ohhh yes, thank you very much for the Information Patrick! I set the RAM to 1300! Now it runs perfectly! Thank you very much for the very fast and good Support! GREAT!

ef86

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]