[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Error upload Public Key with Kgpg

Hi,
i received ths error when i tried to send public key to the server ( onion and clear ) :

libtorsocks(15728): connect: Connection is to a local address (10.152.152.10), may be a TCP DNS request to a local DNS server so have to reject to be safe. Please report a bug to http://code.google.com/p/torsocks/issues/entry if this is preventing a program from working properly with torsocks.

The first message told me that all it’s ok but my key isn’t present to the servers …
I don’t know what i’d do .

Can can try temporarily disabling uwt for kgpg please? (As per https://www.whonix.org/wiki/Stream_Isolation#Environment_Variable_Method.)

I don’t know enough about uwt …
It’s a security problem ?
I don’t want to enstablish a clear connection with KGpg …
However i will see uwt :slight_smile: .

No clearnet connections from within Whonix-Workstation possible unless you make extensive changes to Whonix-Gateway. So no clearnet connection with KGpg.

The security issue is very minor. Pollution of the TransPort, which is a non-perfect stream isolation. You can learn about these nuances by studying that page.

Perhaps i understood uwt wrapper .
I followed your advise and it’s works .
I received these messages on command line :

session D-Bus connection created before QCoreApplication. Application may misbehave
kgpg(9963)/kdeui (kdelibs) KDialogPrivate::queuedLayoutUpdate: KeyExport created with a layout; don’t do that, KDialog takes care of it, use mainWidget or setMainWidget instead .

It seems a GUI problem, but all it’s ok, the key has been uploaded .

For the network problem, i don’t know the real problem, maybe the socks port has some problem, in fact with transport port it runs correctly .
The important thing is to do once a time thing for separating activities when I turn off this wrapper, right ?

That gui message is unrelated. There are many of such messages, for example when starting kate from terminal. Feel free to reproduce them using and against Debian or KDE.

I don’t know why this is happening.

If you run, ‘export UWT_DEV_PASSTHROUGH=“1”’ it’s only active for that one terminal window. Not for the whole system.

Yes, better to not don’t mix up activities using the TransPort.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]