[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Error starting Torbrowser

On 3.2 RC2 I am having a problem starting Torbrowser, with this error.

=====================================================
script bug. ## No panic. Nothing is broken. Just some rare condition ##
has been hit. Try again later. There is likely a ## solution for this
problem. Please see the Whonix News, ## Whonix User Help Forum and
Whonix Documentation. ## https://www.whonix.org/wiki/Tor_Browser

Please report this bug! ## ## BASH_COMMAND:

“$tb_browser_folder/Browser/start-tor-browser” --allow-remote “$@” ##
exit_code: 135 ## ## output: /usr/lib/msgcollector/msgcollector ##
output_opts: --icon /usr/share/icons/anon-icon-pack/tbupdate.ico
–parentpid 9317 --identifier torbrowser --parenttty none --whoami user

progressbaridx: ## ## Experts only: ## bash -x torbrowser

==================================================

Since the error message is pointing to this forum, I thought I’d ask the good people here if they know what is the cause.

It’s a new install and Tor is working.

Thanks

It means that your /home/user/.tb/tor-browser folder is probably broken somehow.

When tb-starter tried to start /home/user/.tb/tor-browser/start-tor-browser it failed and exited with code 135. (There will be a better error message in Whonix 14, but that won’t help your case.) That would most likely also happen if you would try to manually start Tor Browser.

Did you do something not so common such as restoring Tor Browser from a backup or so?

Anyhow. However you run in this this… The easiest would be to reinstall Tor Browser (and loose Tor Browser data) using Tor Browser Downloader (Whonix) in the AppVM where this is happening. See:
( https://www.whonix.org/wiki/Tor_Browser#Update_Tor_Browser )

Fixing this another way / keeping data would be more complicated, let’s hope you don’t need that. Otherwise please say so.

I am not sure what you mean.

Please don’t substitute writing Tor when you mean Tor Browser. ( https://www.whonix.org/wiki/Tor_Browser#Tor_vs_Tor_Browser )

You mean Tor Browser is working anyhow?

Thanks for your reply. I have given up on Qubes 3.2 RC as it’s too buggy on my system, I’ll stick with 3.1 for now. When I installed QubesOS, only the templates were created before the installer crashed, so I had to create the AppVMs from those. All of them worked (those based on Debian, Fedora) apart from Whonix AppVM which had the problems I described.

The AppVM connected to the Tor network without problems (i.e. Tor was working), but TorBrowser wouldn’t start. I didn’t have a backup as this was a new install (on a USB stick).

I didn’t try to reinstall TorBrowser because by then I had decided to give up on this version of Qubes (I had lots of other problems with it too) but if it happens with the next version I certainly will do that.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]