enable Debian stable-updates repository by default

one other issue. buster-updates in the debian “sources.list” is disabled, as is the case with the whonix vms in the past. on the host, this prevents the installation of the qemu-tools package at the moment. if that repo is enabled, the package installs without issue and can be used to shrink the kvm disk images. is it worth considering enabling buster-updates on the host?

Split discussion from Whonix-Host topic.

Could you please link to the package on packages.debian.org? Can’t find it there.

Debian -- Details of package qemu-utils in buster is in buster. There is no buster-backports or buster-updates.


Maybe generally a good idea to enable stable updates?

Previously I didn’t see much point. Reconsidering now.

Debian Mailing Lists -- Index for debian-stable-announce announces what’s going on at stable-updates.

[SUA 173-1] Updated python-acme version - would have been useful.

Looks like it is for non-security important bug fixes.

1 Like

the link you have is the same as mine.

however, when i tried to install qemu-utils, i got the error that it wasn’t available, but referred to by another package. i enabled the “buster-updates” repo in “/etc/apt/sources.list.d/debian.list,” ran “apt-get-update-plus install qemu-utils” and it installed without issue. so, there appears to be some type of conflict that involves the lack of “buster-updates.”

btw, on my vanilla based debian installs, where the wiki instructions were followed to install the needed kvm packages to run the whonix kvm images, i didn’t need to run a separate “apt-get install qemu-utils” command if i recall correctly. the package was installed by default as a recommendation most likely. i’ll test later. but, that was likely the case because “buster-updates” is enabled by default in vanilla debian.

edit: confirmed. with the standard install of debian buster, from the “unofficial” iso, the following command quoted under the wiki instructions link for whonix kvm installs “qemu-utils.” the only immediate difference i can think of there is that “buster-updates” is enabled as a repo.

to test it:

sudo apt-get install qemu-kvm libvirt-daemon-system libvirt-clients virt-manager gir1.2-spiceclientgtk-3.0

the above command on regular debian will install “qemu-utils” as a recommended package. an attempt to install qemu-utils on “whonix host” at the moment will fail. the difference that worked for me was enabling “buster-updates” in the debian repo sources.list.

addtional edit: to make it clear, i bring this up only in reference to “whonix host.” if there is a reason to keep buster-updates disabled in the virtual machines, that’s probably fine. i only caught it in relation to trying to run a utility that usually appeared by default that i use to shrink disk images. this utility does not need to be present in the virtual machines. but, at least at the moment, it appears that “buster-updates” needs to be enabled to install “qemu-utils” on “whonix host.”

1 Like

i am going to test this again. booting into “whonix host” live, and installing the package there works without issue. this happened after i installed it to a persistent drive. so, it may involve some weird package. let me make sure this isn’t some anomaly i’m encountering.

1 Like

you may be able to delete my posts here. i re-installed a persistent whonix host on a usb drive, ran “apt-get-update-plus install qemu-utils” and it installed without issue.

i then purged “qemu-utils,” ran “apt-get-update-plus dist-upgrade” and then ran “apt-get-update-plus install qemu-utils”. it installed without issue.

i’m not sure what the issue was where the host was complaining about it being uninstallable. but, it occurred on 2 fresh installs of a persistent whonix host to a usb. maybe a sync issue? i don’t know. but, maybe others want to give a test? i encountered this issue on two fresh installs.

either way, it may not need to take away from the question of “buster-updates” being enabled. but, on my last test, the problem didn’t occur.

on a side note, maybe “qemu-utils” should be installed in advance on whonix host with the distro image?

1 Like

i can confidentally confirm this was an anomaly at this point. while i’m not sure what caused it, i’ve done installs of both encrypted and unencrypted whonix host persistent to a usb drive, and the issue isn’t occurring. my apologies for raising the alarm. however, i didn’t do anything strange with the installs where the issue appeared. i did a dist-upgrade and tried to install the package. ran into the error. it’s not happening now.

1 Like

Going to repost here Whonix host operating system - #264 by Patrick