[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Electrum and Tor update?

Hello

  1. How do I manually update my Electrum wallet?
    Version 4.0.2 is available now (it’s still 3.3.8 in Whonix Workstation), but I don’t know if I just need to download AppImage and run?
    Possibly the question is there will be an official WW update?

  2. When will the Tor package in WG be updated to version 0.4.2.8?
    Does it depend on Whonix or on Debian?

Best Regards!

You probably shouldn’t unless you verify the upstream devs signatures on their Appimage release. If this sounds difficult just wait until the newer version is uploaded to our repo.

When time permits :slight_smile: Let us know if there is an emergency security fix in this release and you may get it sooner.

1 Like

Indeed.

Helia via Whonix Forum:

  1. How do I manually update my Electrum wallet?
    Version 4.0.2 is available now (it’s still 3.3.8 in Whonix Workstation), but I don’t know if I just need to download AppImage and run?

Updated today.

  1. When will the Tor package in WG be updated to version 0.4.2.8?

It’s currently in stable-proposed-updates and testers repository. See also:

There is significant issue with Electrum in Whonix 16.

The last version of Electrum is 4.1.5.

Version 4.1.4 is in Whonix 15.

Version 4.0.9 only is in Whonix 16.

Therefore Whonix 16 does not allow:

  1. to use Bitcoin Lightning Network and other important options which are simple in Whonix 15

  2. to transfer files with new bitcoin wallets and channels from Whonix 15 to Whonix 16

We use the appimage instead because development moves much faster than even Debian backports can handle.

Current option:

Deprecated as announced in Whonix 16 has been Released! (Debian 11 bullseye based) - for VirtualBox - Major Release.

Did you use this solution on Whonix 16? The solution has incorrect lines and links to non-existent files.

scurl-download https://download.electrum.org/4.1.5/electrum-4.1.5-x86_64.AppImage.asc
gpg --verify electrum-4.1.5-x86_64.AppImage.asc

This address from the line and electrum-4.1.5-x86_64.AppImage.asc file does not exist.

I downloaded another asc from here. And I received this error on the verification:

gpg: no signed data
gpg: can't hash datafile: No data

Please check the solution and correct it if possible.

Did you use appimage on Whonix 16 and actual Electrum version?

Untestedas per:

Please fix the documentation. It’s unspecific to Whonix.

Wiki-guide how to install actual Electrum 4.1.5 is wrong (incorrect commands and non-existent files). Here is real tutorial. I checked it on Whonix 16:

scurl-download https://raw.githubusercontent.com/spesmilo/electrum/master/pubkeys/ThomasV.asc
gpg --keyid-format long --import --import-options show-only --with-fingerprint ThomasV.asc
gpg --import ThomasV.asc
scurl-download https://download.electrum.org/4.1.5/electrum-4.1.5-x86_64.AppImage
file electrum-4.1.5-x86_64.AppImage
scurl-download https://download.electrum.org/4.1.5/electrum-4.1.5-x86_64.AppImage.ThomasV.asc

Than you have to open your folder, find file “electrum-4.1.5-x86_64.AppImage.ThomasV.asc” and rename it to “electrum-4.1.5-x86_64.AppImage.asc”. And after:

gpg --verify electrum-4.1.5-x86_64.AppImage.asc
chmod +x electrum-4.1.5-x86_64.AppImage

Run Electrum 4.1.5 with as usual:

./electrum-4.1.5-x86_64.AppImage

Could you edit the wiki please?

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]