dnsmasq, networks, and kvm

in var/lib/libvirt/dnsmasq what should be included in this folder? i searched by couldnt find much.

i have:


the thing is some of the files were “last modified” on days that i did not use libvirt at all.

when i open the files, they are pretty much empty. one shows an autoconfig file.

I normally wouldnt even look in here, but today i tried to open whonix, but got something like “error"broken pipe”". i restarted my machine and whonix booted up fine without the error.

any thoughts? im on a fedora host

I don’t know what you’re trying to accomplish here.

You really shouldn’t mess with the libvirt dnsmasq config so you don’t cause unknown security problems.

I am trying to gain understanding. I am used to tails where it is set it and forget it - upgrade when the prompt tells you to upgrade. i read through all the documentation here and learned a lot and made the switch.

so i guess what i am trying to accomplish is to figure out what this “error: failed something broken pipe” is.

trying to figure it out, i looked at all of the folders. the dnsmasq caught my attention because they were “last modified” on a day i know i did not open whonix at all.

i followed the directions step by step and everything worked perfectly until this.

it is of note that it did the same thing again today. i restart my machine and then it opens up fine.

i did not touch or edit any files at all. i was just in the file manager clicking through them and looking at them. i wouldnt trust myself at all to edit any of these files

Could be a SELinux problem? The modification could have happened because the daemon was updated that day.