[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Disable torbrowser's about:tor page on startup

Every time I start torbrowser the about:tor page opens. I’ve tried a number of things to stop this behaviour, including some tinkering in about:config, but still about:tor prevails. I don’t need it shown, and because of some custom configuration, I am always told that ‘tor isn’t working’.

It’s very annoying having it pop up with every new torbrowser launch. If possible I do wish to retain it for my main torbrowser, but for my other custom config torbrowsers I don’t want it happening. Can someone explain how to disable it? Many thanks.

Every time I start torbrowser the about:tor page opens.
Using what method?

When using /home/user/tor-browser_en-US/start-tor-browser directly, in Whonix 9, that is stock behavior in any case. That means, the same would happen on plain Debian. Then https://www.whonix.org/wiki/About#Based_on_Debian applies. If you reproduce it on plain Debian, you get the ability to ask support questions and feature requests to The Tor Project.

The desktop / start menu icons have been added by Whonix.

package:

main script:

What page to auto open is currently not configureable, but changing LINK=“about:blank” to something else should be not be that hard. I can make that configureable for Whonix 10 through an /etc/torbrowser.d config snippet. No big effort.

and because of some custom configuration, I am always told that 'tor isn't working'.
This can be a bad sign for anonymity by the way.
If possible I do wish to retain it for my main torbrowser, but for my other custom config torbrowsers I don't want it happening. Can someone explain how to disable it?
I am not sure what you're asking. You are using two parallel installations of Tor Browser in different folders? Please see also my signature about effective bug reports.

I have multiple torbrowser installations, one standard one that connects straight through tor, and multiple others that each have a different tunnelled IP/proxy.

All of that works fine. My custom homepage works fine too. What is annoying however is that every time I open torbrowser, I get my homepage, and a few seconds later the about:tor tab opens and takes window focus and I have to close it. It’s a minor quirk but annoying when it’s constant.

The method I use to start my custom torbrowser installations is indeed ‘/home/user/tor-browser1_en-US/start-tor-browser’, with tor-browser2 and tor-browser3 etc. for my other custom installations.

I don’t really see it as a bug, I just though I was missing something and that there was some simple way of disabling the about:tor page manually. If you could make it configurable in Whonix 10 that would be great.

Thanks for your fast reply Patrick, I hope I’ve made some sense.

I made the configureable through TB_CUSTOM_HOMEPAGE variable (https://github.com/Whonix/tb-starter/commit/4e9277a3b07406e02f58915b8feecddb8d371e44) but that will only apply to default installation paths, such as /home/user/tor-browser_en-US/start-tor-browser, i.e. started though the start menu entries (Whonix created them) / the torbrowser startup script.

What you do with custom installs such as /home/user/tor-browser1_en-US/start-tor-browser is up to you. Whonix doesn’t produce Tor Browser, so you’re left with whatever upstream (The Tor Project) provides.

You can try creating your own startup script.

#!/bin/bash
/home/user/tor-browser1_en-US/start-tor-browser --allow-remote --new-tab https://some.home.page

Or you can try using the new environment variable TOR_DEFAULT_HOMEPAGE (https://trac.torproject.org/projects/tor/ticket/13835).

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]