[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [CONTRIBUTE] [DONATE]

Dbus failed to start.

I was looking into hardening my workstation when I followed some of this article.
www dot dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd dot onion/wiki/Security-misc#Restrict_Hardware_Information_to_Root
I pasted in the commands
sudo systemctl enable hide-hardware-info.service
sudoedit /etc/hide-hardware-info.d/30_whitelist.conf
This command did work but I know there was a file in there with a similar name that I edited.
then i uncommented
sysfs_whitelist=0
and
cpuinfo_whitelist=0
I also set a password for the root account. After rebooting it give me errors saying Dbus failed to start and is asking me for a username and password. I typed in the username user for the default account and it’s password but it didn’t work. Is this reversible? or should I reinstall whonix and start over.

Already mentioned in documentation:

Note that this setting will break many applications; for example, the desktop environment will not even start. Do not perform this action unless you understand the implications and can reverse the change.


Ahhh ok thank you this helped a lot. All I needed to do was type in root password in recovery mode and recomment those two lines in that file.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Contributors] [Investors] [Priority Support] [Professional Support]