[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Custom-Workstation wont run with .iso

kali

#1

I have tried whonix custom workstation with kali as i have seen many videos/tutorials more than anything just talking about how to connect whonix-gw to kali linux in vbox. So i have tried the custom-workstation method:

  • Using .iso version of kali linux it just wont start or move to the next step when you press “start” button:

custom2

  • Using .ova version of kali linux , an error message will appear saying:


#2

Hi TNT_BOM_BOM

This is a VirtualBox issue not Whonix. These error messages are fairly common so I would search the Vbox forums. If there is a solution it would likely be found there.


#3

it was mentioned in the wiki to report it in whonix forum. on the same time , if whonix took a feature from vbox and this feature tested and not working then it should be reported here first not there. then if the issue confirmed to be purely from vbox then on that time we go and report it there and see.


#4

What feature?

A non-Whonix image which will not booting in VirtualBox is a VirtualBox problem.

Example;

If I had a problem creating a Debian VM in Qubes dom0, its a Qubes OS problem. This still holds true even if i intend to use the Debian VM as a Custom Whonix-Workstation.


#5

Maybe i should clarify more, whonix has an .ova image called Custom-Whonix-Workstation you can find it here:

https://download.whonix.org/linux/14.0.0.9.9/

once the user download it and import it in vbox he can then use his own OS to be installed inside this custom-workstation.

so this should be reported here first, then after we confirm its purely vbox issue and whonix has no hands in this issue on how to fix it then we shift our ticket to vbox.


#6

Ah, that makes cents now. You didn’t clarify that i.e. steps to reproduce.


#7

TNT

So, the problem in not with the Developer’s only custom Whonix .iso (link you provided).

once the user download it and import it in vbox he can then use his own OS to be installed inside this custom-workstation.

This issue is with Nested Virtulization in VirtualBox. Correct? Meaning you burned a Kali Linux (not provided by Whonix developers) .iso image and installed in a custom Whonix-Workstation.

This is why “steps to reproduce” are important. No ambiguity.


#8

The steps of producing this are very simple:

install vbox -> import custom-whonix-workstation -> try to make it work for its purpose e.g: try install/import .iso distro inside it see if it will work with you.

simple as that, try to make it work.


#9

Thank you.

Did you verify the kali image, custom whonix image? Also did you try running the Kali iso in Virtualbox by itself?

Does nested virtualization work with the current stable Whonix image?

Did you find anything with the errors messages? Vbox forums etc?

What else have you tried?


#10

Yes.

how is that related? but i have tested that before and it found to be yes.

http://forums.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion/t/nested-visualization-with-whonix-vbox-windows-7-inside-whonix-ws/2001

You can press on next when you import .iso , so not vbox issue until proven.


#11

If it doesn’t work with stable Whonix then it is not just an issue with the Custom Whonix image.

You prove by searching for error messages and finding other users that have encountered the same issue and have found a solution. https://whonix.org/wiki/Support#Free_Support_Principle appllies to everyone.


#12

r u sure you know what is the purpose of custom-whonix-workstation that we already have?

it sound you dont, and its better to test things before you jump to conclusions.

Small Advise of 2019: change the cannabis market that you buy from. Dont thank me for that :blush:


#13

It doesn’t matter what the purpose of the custom-w-s If they both use the same version of VBox then…

Correct


#14

That link is for developers only.

The Whonix-Custom-Workstation ova download is referenced from:

https://www.whonix.org/wiki/Other_Operating_Systems