[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Creating a passthrough .vdi data HD in workstation prevents it from booting.

I am following the anonguide to install whonix on Debian wheezy.
When I get to the chapter for creating an independent HD to hold the data and doing so by pressing settings in virtualbox when workstation is highlighted, on the left menu that appears, selecting storage then adding the HD and setting it’s size, etc. all is fine. But when booting the workstation I get error: cannot find boot partition. Actually i am supposed to use fdisk here after booting to create the data HD partition and format the .vdi HD. If I disable the HD (or just disconnect it from the workstation), then workstaion boots normally. Anonguide may be a bit behind on the virtualbox and whonix updates and it may be that making a data HD in workstation is a bit different now.
Anyone who knows how, please help.

That probably has nothing to do with what is on the Whonix disk image.

It’s probably about the virtual BIOS boot order. Try changing the order of disks so the the original disk is disk 1 and the additional one is disk 2.

Ooops. There is a BIOS for the whonix virtual drives? How can I access it? I tried to find the drives letters for the workstation and gateway and the .vdi drive, but it was always just the virtualbox folder, I could not find any assigned drive letters.

Good day,

May be found under “Settings”.

Have a nice day,

Ego

1 Like

Just some more background. This answer is not required to solve your issue.

picoult:

There is a BIOS for the whonix virtual drives?

No BIOS for the virtual drives. There is a BIOS of the virtual motherboard.

How can I
access it?

You cannot. That virtual BIOS has not settings menu. And you won’t need
them. Would be fun if the virtual BIOS had settings, but well, playthings.

Boot sequence is determined by the order of drives in virtualbox settings.

This is how the drives appear.

Try not adding a new controller. Reuse the same controller. Connect a new disk to the existing sas controller.

Yes you are right. It worked when I made it under the sas.

Thank you.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]