[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Check Result: Could not check for software updates! (apt-get code: 100)

#1

Whonixcheck GUI output, in Qubes-Whonix anon-whonix VM:

INFO: Whonix APT Repository: Enabled. When the Whonix team releases STRETCH updates, they will be AUTOMATICALLY installed (when you run apt-get dist-upgrade) along with updated packages from the Debian team. Please read https://www.whonix.org/wiki/Trust to understand the risk. If you want to change this, use: 
dom0 -> Start Menu -> Template: whonix-gw-14 -> Whonix Repository 
WARNING: Debian Package Update Check Result: Could not check for software updates! (apt-get code: 100) 
Please manually check inside your 'whonix-gw-14' TemplateVM. 
1. Open a TemplateVM terminal. (dom0 -> Start Menu -> Template: whonix-gw-14 -> Terminal) 
2. Update. 
sudo apt-get-update-plus dist-upgrade
3. Shutdown your TemplateVM. (dom0 -> Qubes VM Manager -> right click 'whonix-gw-14' -> Shutdown VM) 
4. Shutdown and restart this TemplateBased ProxyVM. (dom0 -> Qubes VM Manager -> right click 'sys-whonix' -> Shutdown VM)

I did follow the instructions, here’s log output of “sudo apt-get-update-plus dist-upgrade” run on whonix-gw-14 terminal:

user@host:~$ sudo apt-get-update-plus dist-upgrade
Hit:1 tor+http://deb.dds6qkxpwdeubwucdiaord2xgbbeyds25rbsgr73tbfpqpt4a6vjwsyd.onion stretch InRelease
Hit:2 https://deb.whonix.org stretch InRelease
Hit:4 https://deb.qubes-os.org/r4.0/vm stretch InRelease
Hit:3 https://cdn-aws.deb.debian.org/debian-security stretch/updates InRelease
Ign:5 https://cdn-aws.deb.debian.org/debian stretch InRelease
Hit:6 https://cdn-aws.deb.debian.org/debian stretch Release
Reading package lists...
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
user@host:~$ 

I then proceeded to restart everything. The Warning persists.

I’ve set during Qubes R4.0 installation to use Whonix to update Dom0, and if the option was present also the templateVMs (I don’t recall if it was present or not atm, but if it was, I definitely checked that box), regardless of that I’ve set all my template VMs to sys-whonix.
I also changed the “tor+http” links in /etc/apt/sources.list.d/whonix.list to just “http” (was afraid of tor over tor) since the netvm is set to sys-whonix already. As you can see in the log above I changed it back to “tor+http” to make sure this error isn’t my fault.
These are the modifications I did, I don’t think they are responsible for the Warning message.

How to fix it please? Any clue?

#2

Sorry I can’t find the “Edit” button so I have to manually reply to fix the typo.
I meant I set sys-whonix as the NetVM of all my templates.*

#3

Are you sure that you already have a connection to the internet while running whonixcheck?

Have you added any steps from this guide?

You won’t get tor over tor from that. That just uses the onion service mirrors.

The edit button is the pencil icon next to the reply button.

edit

2 Likes
#4

This can be mysterious. Happens to me too sometimes. I consider this a minor bug since whonixcheck already advises what to do in that situation. Won’t fix in Whonix 14. Recently finally had an idea how to debug this. This was improved in Whonix 15. (One could copy over this code change manually.)

In Whonix 15 when running whonixcheck --verbose
(which is usually not recommended for users since it shows some messages which could only lead to questions in the forums which aren’t helpful as per https://www.whonix.org/wiki/FAQ#Non-Responsiveness_to_Concerns)
it shows the literal output of what is happening. This might help finding out why this is happening.

1 Like
#5

Yes, 100%.

Oh, makes sense. Thanks for letting me know.

Found it now. It’s missing the Icon in Tor Browser here, making it invisible. Could be because I’m using the onion mirror for the Whonix Forum.
Thank you for the answers @madaidan

Nice to know.

Absolutely.

Got it, won’t post any questions in relation to the verbose output in case I decide to debug the warning message.

Good, was initially worried of an attack against my Whonix instance, glad to know it’s not ringing any bells as such.

Thank you for the answers @Patrick