Catch 22 while adding bridges


I am stuck in adding bridges to whonix-gateway.

  1. Tor is blocked in my country so I cannot use Host to get bridges.

  2. Cannot use internet browser in whonix-gateway.

  3. Can open Tor bridge database in whonix-workstation but then cannot copy/paste this between virtual machines or even workstation to host (it’s disabled by design).

  4. Got frustrated and tried to install firefox or tor bundle in gateway but not getting through.

I know how to add bridges in torrc file but the issue is, how on earth I get bridges info in gateway for adding to torrc file?

Please suggest solution other than telling me to have both VMs side by side and add by manually typing bridges.

Thank you.

First option: Receiving Tor Bridges by email

That is, email with the line “get bridges” by itself in the body of the mail.

Although this must be done from a Gmail, Riseup! or Yahoo account. Which means you need a load of personal information to signup in the first place, or in Riseup’s case, invites.

Difficult or privacy invading. Not a good option.

Option Two: Cutting and pasting

A piece of cake in Qubes-Whonix.

Ctrl+C → Ctrl+Shift+C → Change VM Focus → Ctrl+Shift+V → Ctrl+V

In “normal” Whonix, I think it’s blocked for security reasons i.e. WS → GW (unless the experts point out otherwise on this thread).

Option 3: Manual typing

While it is annoying, I don’t see the big deal.

For each bridge entry, you have around 16 characters for the IP address and port.

Then around 40 characters following each entry for the bridge fingerprint (i.e so Tor can verify the relay running at that location has the right fingerprint & it’s used to look up the bridge descriptor at the bridge authority).

If the difference between not being able to use Tor in a hostile nation state and having a functional bridge connection is 5-10 minutes of your time to manually type these entries and then double (triple) check them, then it’s worth it.

If you entered them wrong, they’re just not gonna work.