[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Can't install Retroshare

[CODE]$ sudo dpkg -i retroshare06_0.6.0-0.8551~sid_i386.deb
(Reading database … 115769 files and directories currently installed.)
Preparing to replace retroshare06 0.6.0-0.8551~sid (using retroshare06_0.6.0-0.8551~sid_i386.deb) …
Unpacking replacement retroshare06 …
dpkg: dependency problems prevent configuration of retroshare06:
retroshare06 depends on libsqlcipher0 (>= 1.1.9); however:
Package libsqlcipher0 is not installed.
retroshare06 depends on libstdc++6 (>= 4.9); however:
Version of libstdc++6:i386 on system is 4.7.2-5.
retroshare06 depends on gnome-keyring; however:
Package gnome-keyring is not installed.

dpkg: error processing retroshare06 (–install):
dependency problems - leaving unconfigured
Processing triggers for hicolor-icon-theme …
Errors were encountered while processing:
retroshare06
[/CODE]

I tried to install the packages as in a guide for Wheezy but didn’t work:

$ sudo apt-get install libglib2.0-dev libupnp-dev qt4-dev-tools libqt4-dev libssl-dev libxss-dev libgnome-keyring-dev libbz2-dev libqt4-opengl-dev libqtmultimediakit1 qtmobility-dev libspeex-dev libspeexdsp-dev libxslt1-dev libprotobuf-dev protobuf-compiler cmake libcurl4-openssl-dev Reading package lists... Done Building dependency tree Reading state information... Done libssl-dev is already the newest version. libssl-dev set to manually installed. libqt4-dev is already the newest version. libqt4-dev set to manually installed. libqt4-opengl-dev is already the newest version. libqt4-opengl-dev set to manually installed. You might want to run 'apt-get -f install' to correct these: The following packages have unmet dependencies: cmake : Depends: libxmlrpc-core-c3 but it is not going to be installed Depends: cmake-data (= 2.8.9-1) but it is not going to be installed libcurl4-openssl-dev : Depends: libidn11-dev but it is not going to be installed Depends: libkrb5-dev but it is not going to be installed Depends: libldap2-dev but it is not going to be installed Depends: librtmp-dev but it is not going to be installed Depends: libssh2-1-dev but it is not going to be installed libglib2.0-dev : Depends: libglib2.0-bin (= 2.33.12+really2.32.4-5) but it is not going to be installed Depends: libpcre3-dev (>= 8.11) but it is not going to be installed Depends: pkg-config (>= 0.16.0) but it is not going to be installed libgnome-keyring-dev : Depends: gir1.2-gnomekeyring-1.0 (= 3.4.1-1) but it is not going to be installed libprotobuf-dev : Depends: libprotobuf7 (= 2.4.1-3) but it is not going to be installed Depends: libprotobuf-lite7 (= 2.4.1-3) but it is not going to be installed libupnp-dev : Depends: libupnp6-dev (>= 1:1.6.17-1.2) but it is not going to be installed libxslt1-dev : Depends: libxml2-dev (>= 2.6.26) but it is not going to be installed libxss-dev : Depends: x11proto-scrnsaver-dev (>= 1.2.0) but it is not going to be installed protobuf-compiler : Depends: libprotobuf7 but it is not going to be installed Depends: libprotoc7 (= 2.4.1-3) but it is not going to be installed qt4-dev-tools : Depends: libqt4-sql-sqlite but it is not going to be installed Depends: libqt4-declarative (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqt4-help (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqt4-network (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqt4-sql (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqt4-xml (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqt4-xmlpatterns (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqtcore4 (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqtdbus4 (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Depends: libqtgui4 (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed Recommends: qt4-designer but it is not going to be installed Recommends: qt4-doc but it is not going to be installed qtchooser : Breaks: qt4-dev-tools (<= 4:4.8.4+dfsg-1~) but 4:4.8.2+dfsg-11 is to be installed qtmobility-dev : Depends: libqtconnectivity1 (= 1.2.0-3) but it is not going to be installed Depends: libqtcontacts1 (= 1.2.0-3) but it is not going to be installed Depends: libqtfeedback1 (= 1.2.0-3) but it is not going to be installed Depends: libqtgallery1 (= 1.2.0-3) but it is not going to be installed Depends: libqtlocation1 (= 1.2.0-3) but it is not going to be installed Depends: libqtmessaging1 (= 1.2.0-3) but it is not going to be installed Depends: libqtorganizer1 (= 1.2.0-3) but it is not going to be installed Depends: libqtpublishsubscribe1 (= 1.2.0-3) but it is not going to be installed Depends: libqtsensors1 (= 1.2.0-3) but it is not going to be installed Depends: libqtserviceframework1 (= 1.2.0-3) but it is not going to be installed Depends: libqtsysteminfo1 (= 1.2.0-3) but it is not going to be installed Depends: libqtversit1 (= 1.2.0-3) but it is not going to be installed Depends: libqtversitorganizer1 (= 1.2.0-3) but it is not going to be installed Depends: servicefw but it is not going to be installed retroshare06 : Depends: libsqlcipher0 (>= 1.1.9) but it is not installable Depends: libstdc++6 (>= 4.9) but 4.7.2-5 is to be installed Depends: gnome-keyring but it is not going to be installed E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

I haven’t tried myself. But apparently you tried installing retroshare sid version on wheezy. Probably won’t work. Check if there is a wheezy version. Please also see:


i.e. if you get this to work on Debian wheezy, you should be able to do the same on Whonix 10.

I googled these instructions for installing it in Wheezy:

[CODE]# install build-dependencys:
apt-get install cmake debhelper libbz2-dev libcurl4-openssl-dev libglib2.0-dev libgnome-keyring-dev libgpgme11-dev libprotobuf-dev libqt4-dev libqt4-opengl-dev libspeex-dev libspeexdsp-dev libssl-dev libupnp6-dev libupnp-dev libx11-dev libxslt1-dev libxss-dev protobuf-compiler qt4-dev-tools qt4-qmake dpkg-dev

download the latest RetroShare .tar.gz and unpack

tar xf RetroShare-xxxx.tar.gz
cd retroshare-xxxx/

eeventually remove all VOIP stuff from

src/plugins/Makefile src/Makefile debian/control

when you get some errors compiling the voip-plugin

dpkg-buildpackage

the .deb packages are then in …/[/CODE]

I used aptitude isntead of apt-get this time and still can’t compile:

$ sudo dpkg-buildpackagedpkg-buildpackage: source package retroshare06 dpkg-buildpackage: source version 0.6.0-0.8551~sid dpkg-buildpackage: source changed by Cyril Soler <csoler@users.sourceforge.net> dpkg-buildpackage: host architecture i386 dpkg-source --before-build retroshare06-0.6.0 dpkg-checkbuilddeps: Unmet build dependencies: libsqlcipher-dev dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting dpkg-buildpackage: warning: (Use -d flag to override.)

Googled it and the solution didn’t work:

[CODE]Edit /etc/apt/sources.list as described in official instructions from Debian.

root@kopimi:~# vi /etc/apt/sources.list

And add the line:

deb http://http.debian.net/debian wheezy-backports main

and now we can install libsqlcipher-dev[/CODE]

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]