[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Can't get Whonix Gateway to connect

I have been away from KVM and even linux for a few years. I had previously run Whonix via KVM back then but am having a problem now.

First, I’m on Mageia 7.1 (rpm-based) distro. I have the latest available Whonix qcow2 files. I setup KVM as per instructions but when I start Whonix-Gateway it fails to connect to the internet and produces an error message that network device eth1 didn’t come up.
If I do “ipconfig” on my host I have multiple virbr# interfaces. The only one that seems to have an ip address associated is virbr1:

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 180 bytes 16040 (15.6 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 180 bytes 16040 (15.6 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 52:54:00:6d:34:1c txqueuelen 1000 (Ethernet)
RX packets 26 bytes 1196 (1.1 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

virbr1: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
inet 10.0.2.2 netmask 255.255.255.0 broadcast 10.0.2.255
ether 52:54:00:d4:05:d7 txqueuelen 1000 (Ethernet)
RX packets 0 bytes 0 (0.0 B)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

virbr2: flags=4099<UP,BROADCAST,MULTICAST> mtu 1500
ether 52:54:00:f5:77:b8 txqueuelen 1000 (Ethernet)
RX packets 1500 bytes 69000 (67.3 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 0 bytes 0 (0.0 B)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

One question I have is do I need the other virbr# devices and can I get rid of them (they are KVM specific are they not? I also have Virtualbox installed but I don’t recall it ever using such interfaces). I am assuming that for some reason Whonix-Gateway is not connecting via the correct virbr# and therefore eth1 in Whonix doesn’t come up(?).

  1. Do I need the multple virbr# net interfaces or are they artifacts of me running the virsh commands multiple times? If not, how do I get rid of the extraneous ones?
  2. How do I get Whonix-Gateway to see the correct virbr# interface? Is that some setting I make on the host and to KVM/QEMU related settings or to the settings for the Whonix-Gateway VM? Or some setting IN Whonix-Gateway?

Make sure you remove any networks not called ‘default’ then try again with importing the newer network files supplied. Much has changed in Whonix KVM networking since you last installed it.

OK. Thank you. How do I identify the interface labeled default and get rid of the others. My Google searching hasn’t been very successful, finding only more general or tangentially related info.

I’ve made a few changes and progress but gotten nowhere. I did find how to eliminate virbr0, leaving me with virbr1 and virbr2, with virbr1 equating to “Whonix-external” network - the interface connecting to my real internet connection, supposedly (wi-fi) with an IP address of 10.0.2.2. But then I rebooted and virbr0 is back and has an IP address (this time) of 192.168.122.1. And virbr2 is “Whonix-internal” for workstation to connect to the gateway (I followed instructions and got to this point…is it wrong?). I STILL don’t get an internet connection in the Gateway. I STILL get the error message that eth1 didn’t come up. I see no way to look at the net interfaces because there’s no ipconfig tool so I can’t even look at what interfaces Whonix even has. It is clear that Whonix and KVM have changed over the last 3 to 4 years because I did not have this kind of problem before. It has gotten more complicated rather than better. Apparently. HOW DO I GET AN INTERNET CONNECTION for the Gateway and what, exactly, are the interfaces needed for Whonix to work (just virbr0 or a Whonix-external and separate Whonix-internal interface?

Virt machine manager -> edit -> connection details -> virtual networks

Remove anything besides default then try reimporting the new network file

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]