Can't connect to Bitmessage with whonix 9

In the Bitmessage proxy setting I have:

Socks5 9152

but it doesn’t connect.

Whenever i use no proxy, it connects upon startup but then drops all connections.
I’ve read all the Stream Isolation and related stuff but cannot get this to work.

Using Whonix with physical isolation, VirtualBox, KVM or Qubes?

Same question here.


Hi Bleezer

Same issue here, maybe we could groupe the two topics together ?!?

EDIT 1 : I tried the solution proposed by @Patrick Firewall_Unload without success until now. Still the red light and no connection.

@Bleezer what version of Bitmessage do you use ? Can you find the file debug.log ?
@Raccoon_090A5AE6 : do you also have a connection issue ? If so same questions as to Bleezer, what version and do you find somewhere the debug.log ?

I personally use the v0.6.3.2 version which seems to be the latest and very buggy… A solution could be using an older version v0.5.8. Haven’t tested it yet…

Thank you for your feedbacks.

Hi Cottonwoodhill

Have you tried installing Bitmessage in a Debian 9 VM? Are you able to connect over clearnet? (Just for testing purpses)


Hi 0brand

I haven’t thought about testing it this way :wink: Well done :sunglasses:

I will install a Debian 9 and see if the Bitmessage v0.6.3.2 also bugs.

Feedback will be posted here in a few days :slight_smile:

1 Like

Hi @,

So here is an update after having installed Bitmessage in a fresh Debian 9 on a VM as suggested by 0brand.

Verdict : Connection was working :astonished:

So I went back to my Whonix Workstation and used the version I found and downloaded here :

And guess what ? I am glad to inform you that connection also works on Whonix :smile:

Just use the latest release

This is the same version I used on my Debian connected on freenet.

The problem was from my point of view that I was using a beta version and I was not aware about that…

Hope it helps :wink:

What about you guys who encountered some problems with your connection ?

1 Like

Hi Cottonwoodhill`

Thanks for testing! !Once I’ve had a chance to test I’ll submit an update to the wiki. Unless of course you’d be interested in making a wiki contribution. :slight_smile:

Dear 0brand,

Thank you for having suggested me this research as it contributed to find out how to solve my issue (and maybe/hopefully some from other users) :slightly_smiling_face:

The question about making an update to the wiki is clear : if I were able to do it, I would be glad to contribute without hesitation to the Whonix community by doing it. But I am far away of a confirmed user of the Unix world.

I’m sailing at sight, day after day :sailboat:

Anyway, I am flattered by your proposal :blush: and remain at your disposal :wink:

1 Like