Can't boot to GUI on gateway after update

Hi everyone,

I need assistance.

I am unable to boot to the GUI after I have updated whonix. I can boot to the virtual console which automatically boots to tty2 but I have no idea how to boot to the GUI. I have tried alt + ctrl + F7, I have tried to increase the RAM, it is currently 2048mb, my video memory is 128mb. All of the support I can find is people asking how to boot into the CLI but nothing about booting into the GUI.

Has something changed in the update? It would boot straight into the GUI previously but since I did a full system update I can only get into the CLI. I need the GUI so I can access my password manager, at the moment, I can’t access it.

I have tried systemcheck and it says no updates are required and no there are issues. I am running whonix version 16.


Whonix does not push updates changing the default

  • from “automatically starting the desktop imprisonment” to
  • to “not automatically starting the desktop imprisonment”.

Because that would make no sense and cause major support disruptions. Related design documentation:

(Whonix is based on Kicksecure.)

Therefore that’s not documented.

To start the graphical desktop environment, one has to start a display manager.

At time of writing, Whonix uses gdm3 as display manager. [1] The command to (re)start the display manager gdm3 is:

sudo systemctl restart gdm3

But I think this won’t work because that should happen automatically already.

systemcheck isn’t showing any warnings / errors?

Did you remove a meta package? If so, systemcheck would tell you. Try this:
Re-install Meta Packages and Safely Run Autoremove

Otherwise this a is a broken boot:

[1] Potentially subject to change in the future: display manager - lightdm, gdm3, sddm or no display manager (startx)

Hi Patrick,

Thanks for your quick response.

I did think it would be an odd update if that was the case and I’d have thought I would have found more posts of people experiencing similar issues.

Thanks for the suggestions so far, I did try the restart of gdm3 but it didn’t do anything as you predicted. Systemcheck is showing no errors, connects to Tor with success and says there are no updates/upgrades available. No other errors.

I think we may have got somewhere with me attempting to reinstall the meta packages. I tried to install XFCE and I’ve got the below error.

sudo apt install non-qubes-whonix-gateway-xfce
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
kicksecure-desktop-enviroment-essential-xfce : Depends: gdm3 but it is not installable 
E: Unable to correct problems, you have held broken packages.

Trying to reinstall the gdm3 gives the below error.

sudo apt-get install gdm3
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package gdm3 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package gdm3 has no installation candidate

I’ve tried to do some googling around the error but a lot of the solutions are “try sudo apt-get update” or a similar command. Unfortunately, this isn’t working but I’m not sure if it’s because Whonix is different to Ubuntu and other flavours of Linux so a simple update won’t fix it. I think something may have broke during my update, possibly I ran out of space on my host machine, I have made room but the update command doesn’t seem to fix it.

I did see a post on askubuntu that the above error is because apt doesn’t know what that package is. Do you know of any other way to install gdm3 other than apt-get? I didn’t want to start adding sources which aren’t vetted by Whonix. I could also try replacing the files through the file manager function on Virtualbox if you know of a safe place I can get them.

Thank you

Edit: After typing about the file manager, I just had a thought that I can just take my db file of Keepass from the Gateway. I’m just thinking if it’s easier to scrap this Gateway, do a fresh install and then just move my Keepass DB file back across.

This one is recommended:
Recovery - Kicksecure chapter Hard Drive Recovery in Kicksecure wiki

And this one might fix it:
Operating System Software and Updates - Kicksecure chapter Broken APT in Kicksecure wiki

1 Like