[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Can start and stop VM but can't intercat with it in any other way due to the fact that no window appears

I’ve followed the official Whonix KVM guide. I’m now at the step where I should start the VMs. I can start them both with the GUI and the CLI without error messages. I can see that they are running, but I’m not able to interact with them because no screen appears(I expected that a screen would appear like the one from qemu(without kvm)).
So I can launch it and kill it but nothing else.
The preferences shown by virt-manager for Whonix-Gateway say under Install Graphics “VNC”.
The host operating systems is Trisquel 7.0 GNU/Linux.

Please select spice for graphics because this is what the VMs are configured to use. Its both faster and safer than VNC.

I forgot to say the version of Whonix: 13.0.0.1.4
Shouldn’t spice be the default if it’s better?
I changed it to spice and installed whatever package in my repository seemed to be needed:
gir1.2-spice-client-gtk-3.0; gir1.2-spice-client-glib-2.0; gir1.2-spice-client-gtk-3.0; libspice-client-glib-2.0-8; libspice-client-gtk-3.0-4; libusbredirhost1; spice-client-glib-usb-acl-helper; libspice-client-gtk-2.0-4; gir1.2-spice-client-gtk-2.0; spice-client-gtk

Some of them were dependencies.
The problem remains.

Under hardware at Display Spice I see:
Type - Spice
Address - 127.0.0.1
Port - Automatically allocated
TLS Port - [Same as above]
Password - [Empty]
Keymap - Auto

Under Hardware details at Video QXL I see:
Model - QXL
RAM - 250MB
Heads - 1

I went to View > Console and when I launched the VM it said:
“Cannot display graphical console type 'spice:
No module named SpiceClientGtk”

I’m not really sure what to install. The ones I have installed have very similar names. I’m going to keep looking into the repository.

Going by what your ditro’s install info page says I would try installing this package on the host:

sudo apt-get install python-spice-client-gtk

https://trisquel.info/en/wiki/virtualization-using-kvm

Also make sure you set your video to QXL instead of VGA in your VM. device settings.

2 Likes

I installed the package and now I am able to open the VM’s console.
I should have read my distro’s documentation on the topic.
Thanks. :slight_smile:

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]