Building... a circuit

Today I’ve noticed in Connections tab on Whonix Gateway smth like this: --> Building… Purpose: Ags=is_internal, need_capacity, need_uptime.

There’re 9 circuits, and only topmost only has “Building…”.
I’ve reloaded VM, but nothing has changed.
What does it mean?

The Tor Socks Listen Address is ( Local Host )

It just means a new circuit is being built. Nothing to worry about.

I’ve realized that I have given you an incomplete answer. I told you there is nothing to worry about but I’m sure that will not set your mind at ease without an explanation.

What I believe happened is you may have inadvertently changed one of the ARM settings that controls what information is shown to you on the screen.

I will go through the steps needed for you to bring up the Arm menu so you can configure the settings the way you want.

  1. In a Whonix Gateway konsole run this command to start the Arm tor controller. Also see Whonix Tor Controller.


  2. Press the “m” key. This will bring up the Arm menu in the upper right hand corner of your screen.

  3. Next use your right arrow key to toggle over to the “View” column. Your choices are:


Going on what information you have given I believe you have ‘Connections’’ checked in that column.

  1. Now use your arrow key and toggle over 1 row to the “Connections” column. ( not to be confused with the Connections row from the last step ).

This is wear you will be able to change what information is shown to you on your Arm screen. ( Note: this column will have different values depending what you have checked in the “View” Column ) Your choices are:

 IP Address
  1. More than likely you have Fingerprint checked, however if you want the information format that was shown previously on your Arm screen, IP Address is the one you want checked.

Next Use the up or down arrow key until your choice ( IP Address) is highlighted and press “Enter”