Bridges don't work.

Yes, thank you, bridges work in Anon Connection Wizard. But in the Tor Control panel, bridges don’t work.

Could you please compare the generated configuration file ACW vs TCP? File:


The Tor Control panel now does not start at all.

Try start from command line.

sudo --set-home tor-control-panel


QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to ‘/tmp/runtime-root’
QLayout: Attempting to add QLayout “” to QFrame “”, which already has a layout

Please post error message here, if any.

So that file looks the same for ACW versus TCP?
Or was there a difference ACW versus TCP?

1 Like

I don’t understand what exactly I should compare.

How specifically to compare ACW with TCP?
I don’t even know what ACW is.

ACW - Anon Connection Wizard
TCP - Tor Control Panel

  1. create a config file using TCP
  2. create a config file using ACW
  3. compare or post them both there

redact private information

Thanks for the report.

This is happening because…

You are using the wrong format. You are using:

Bridge IP:PORT

That’s a plain bridge. Not using any pluggable transport such as obfs4. You probably need an obfs4 bridge.

Also please note what that file is saying:

# This file is generated by and should ONLY be used by anon-connection-wizard.
# User configuration should go to /usr/local/etc/torrc.d/50_user.conf, not here. Because:
#    1. This file can be easily overwritten by anon-connection-wizard.
#    2. Even a single character change in this file may cause error.
# However, deleting this file will be fine since a new plain file will be generated the next time you run anon-connection-wizard.

I fixed that bug but it doesn’t really matter.

I recommend to either use ACW or the command line.

“Forget” about TCP. It’s not really needed.

Thank you.
But obfs4 seems to be blocked in our country.


No connection.


There is a connection.

# Do not edit this file!# Please add modifications to the following file inste - - TCP has been used wrong. A proxy has been configured instead a bridge. A bridge is not considered a proxy in TCP / ACW. A bridge is not considered a proxy in context of Tor. Do not use proxy settings unless you want to.

But # This file is generated by and should ONLY be used by anon-connection-wizard. - uses a “plain” bridge. With means no pluggable transport at all. These are the most easy to block bridges. I find it highly unlikely that obfs4 bridges are blocked but plain bridges are functional.

# This file is generated by and should ONLY be used by anon-connection-wizard. - is using a plain bridge.

I didn’t actually use a proxy. I set up a bridge in TCP, not a proxy.

Please post screenshots or a video or detailed description which buttons you pressed in TCP in which order.


Sorry it was my mistake. I just didn’t understand the program. Now everything works as it should.
I inserted the bridge into the proxy on the first page. I’m still learning, I’m new.

I think this information should be added to the wiki.

In the top button I chose “Custom bridges”.
And I thought the bottom button was the bridge setting.