[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Bisq - The P2P Exchange Network

I tried this command on workstation: ./bisq-desktop --torControlPort 9051 --torControlPassword notrequired

Got this error:

Apr-25 01:06:56.345 [NetworkNode-9999] INFO  b.n.p2p.network.RunningTor: Connecting to running tor 
 pr-25 01:06:56.492 [TorControlParser] TRACE o.b.netlayer.tor.Tor: >> AUTHENTICATE 6E6F747265717569726564
Apr-25 01:06:56.493 [TorControlParser] TRACE o.b.netlayer.tor.Tor: << 250 OK 
 pr-25 01:06:56.549 [TorControlParser] TRACE o.b.netlayer.tor.Tor: >> SETEVENTS CIRC WARN ERR
Apr-25 01:06:56.549 [TorControlParser] TRACE o.b.netlayer.tor.Tor: << 510 Command filtered 
Apr-25 01:06:56.550 [NetworkNode-9999] ERROR b.n.p2p.network.TorNetworkNode: Could not connect to running Tor: Error reply: Command filtered 
Apr-25 01:06:56.552 [JavaFX Application Thread] ERROR bisq.core.app.P2PNetworkSetup: onSetupFailed 

This command exits successfully: bash -x tor-ctrl -p notrequired -c "signal newnym"

My Tor Controller knowledge is limited so I would appreciate any troubleshooting suggestions.

Progress was made. Instructions https://www.whonix.org/wiki/Bisq updated. An onion-grater profile was written just now which solves the command filtered issues.

Bisq does not connect yet, says: “No seed nodes available.”

Cause unknown. Bisq has many native Tor issues so it may or may not be an issue caused by Whonix.

Found a bug:

The fix is now in Whonix 15 repository.
For Whonix 14 a workaround is documented.
Bisq is working for me now.
Testers welcome!

https://www.whonix.org/wiki/Bisq

1 Like

Instructions bug fixed and improved clarity yet again.

https://www.whonix.org/wiki/Bisq

Thanks! I’ve been using Bisq in the past inside the Workstation and guess it was Tor over Tor.

The instructions seems a bit scary though. Will it be possible to do it in Whonix 15 without touching the Gateway (include the onion grater profile as default? is it done for other apps?), and without opening all ports in the Workstation?

I feel this is a super important application to have for anyone serious about crypto.

Not that I know.

No, not good to do that by default.

bisq, onionshare, ricochet, zeronet

Not that I know.

I see, so certainly an ideal case for using alternate WS / GW for this purpose.

If we “only” want to avoid Tor over Tor, are there simpler alternatives? for example, revise only usr/local/etc/torrc.d/50_user.conf in the gateway to use a certain exit node, or something of that kind?

Alternatively, ship an “advanced users” version with the configurations you specified already done?

I don’t think so. You’d have to specific the full path through the Tor network, not just the Tor exit and then also make sure the bisq internal Tor client doesn’t do the same.

Alternatively, ship an “advanced users” version with the configurations you specified already done?

Feedback and Suggestions

Edit by Patrick:
See user documentation.


@Patrick I followed the instructions on the wiki that you posted (except that I built from the master branch instead of downloading the binary). The Bisq desktop starts but I can’t connect to a Tor node. Here is the command: ./bisq-desktop --torControlPort 9051 --torControlPasswordrd notrequired --socks5ProxyBtcAddress=127.0.0.1:9050 --useTorForBtc=true

Does this error look familiar?

Apr-30 17:50:42.099 [NetworkNode:SendMessage-to-rm7b56wbrcczpjvl.onion:8000] INFO  b.n.p2p.network.NetworkNode: onFailure at sendMessage: peersNodeAddress=rm7b56wbrcczpjvl.onion:8000
        message=PreliminaryGetDataRequest
        throwable=java.io.IOException: Cannot connect to hidden service
Apr-30 17:50:42.101 [JavaFX Application Thread] INFO  b.n.p.p.g.RequestDataHandler: Sending getDataRequest to rm7b56wbrcczpjvl.onion:8000 failed. That is expected if the peer is offline.
        getDataRequest=PreliminaryGetDataRequest(supportedCapabilities=[0, 1, 2, 5, 6, 7, 8, 9]).
        Exception=Cannot connect to hidden service

I’m using Whonix 15.

Here are my firewall settings:

OK: Loading Whonix firewall...
2019-04-30 18:06:26 - /usr/bin/whonix-workstation-firewall - OK: Skipping firewall mode detection since already set to 'full'.
2019-04-30 18:06:26 - /usr/bin/whonix-workstation-firewall - OK: (Full torified network access allowed.)
OK: The firewall should not show any messages,
OK: besides output beginning with prefix OK:...
OK: Whonix firewall loaded.

Fix was incomplete. Now fixed.

Fix in all repositories.


To test:

This is ok:

curl.anondist-orig --head 127.0.0.1:9050

HTTP/1.0 501 Tor is not an HTTP Proxy
Content-Type: text/html; charset=iso-8859-1

This is not ok:

curl.anondist-orig --head 127.0.0.1:9150

curl: (52) Empty reply from server

This is ok:

curl.anondist-orig --head 127.0.0.1:9150

HTTP/1.0 501 Tor is not an HTTP Proxy
Content-Type: text/html; charset=iso-8859-1

Sorry for the noob question but how do I apply this commit to my existing Whonix environment? Just by running the system updates? If so, do I need to updated form the development repository?

I applied the patch by updating my OS. Bisq is working now! My Whonix workstation is now complete.

1 Like

@Patrick I spoke too soon, it still doesn’t work yet. When trying to take a trade, I get: “You need to wait until you are fully connected to the network. That might take about 2 minutes at startup”. It’s been over an hour since startup but still no connection. The bottom right corner says “Initial data received. / P2P network peers: 8” The log looks clean but I don’t currently trace. Do you experience the same behavior?

No idea. Please consider getting in touch with https://github.com/bisq-network/bisq/issues too. Could be also general bisq and/or bisq general Tor issues.

I’m investigating the issue with them. Nothing helpful so far other than it’s a connection issue. At least one user experienced the identical behavior and fixed by deleting the tor folder contents: https://github.com/bisq-network/bisq/issues/2374#issuecomment-462013773. Is this worth trying? If so, how should I do it? I don’t know exactly what to delete between the Gateway and Workstation.

Can do.

No difference bisq inside vs outside of Whonix.

bisq running in Whonix-Workstation does not create/modify any files on Whonix-Gateway. (It only creates ephemeral Tor hidden services through Tor control protocol.) So no need to worry about selection of any files on Whonix-Gateway.

I reproduced the issue. I also manged to fully connect, fixing this issue but it is not in a secure state yet.

40_bisq.yml has a bug.

To debug this - which may not be save - information how your Tor circuit is constructions - will leak into Whonix-Workstation…

The issue is somewhere here:

  events:
    CIRC:
      suppress: true
    ORCONN:
      suppress: true
    INFO:
      suppress: true
    NOTICE:
      suppress: true
    WARN:
      suppress: true
    ERR:
      suppress: true
    HS_DESC:
      suppress: true
    HS_DESC_CONTENT:
      suppress: true

We can’t just suppress all of these events. For testing purposes, comment out all suppress: true. So it looks like this.

  events:
    CIRC:
      #suppress: true
    ORCONN:
      #suppress: true
    INFO:
      #suppress: true
    NOTICE:
      #suppress: true
    WARN:
      #suppress: true
    ERR:
      #suppress: true
    HS_DESC:
      #suppress: true
    HS_DESC_CONTENT:
      #suppress: true

The restart onion-grater on Whonix-Gateway.

sudo service onion-grater restart

So if you are able to use Bisq in this config. If yes, proceed with debugging below.

Comment in as many suppress: true as possible while Bisq is still fully connecting after Bisq restart, i.e. remove the # and sudo service onion-grater restart. As long as Bisq is saying “Synchronizing DAO” there is no need to proceed - that is the crux.

Once the essential non-supressable events are identified, I can try to write an onion-grater profile which allows using these and is secure at the same time.

Profile was updated.

https://github.com/Whonix/onion-grater/blob/master/usr/share/doc/onion-grater-merger/examples/40_bisq.yml

Should work now.

It works! Thank you so much! I disabled the DAO sync as I don’t need it for now.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]