[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Autostart won't run script

Hii, I’ve written a script (script1.sh), located in /home/user/e which contains:

#!/bin/bash echo "example"

It only runs in konsole after I go to the script in dolphin >rmb>actions>“run in konsole”, or, once I am in konsole, type:

cd /home/user/e sh script1.sh
Not when I double-click it or “rmb>open with>konsole”.

So the script works, and I have added it to autostart as a script, to run at startup, but you can guess it,… it won’t run after startup.

I think it is because the autostart-option opens it like double-click, rather than using the “actions>run with konsole” option.
Do you have any suggestions to make sure it does automatically run at startup?

Depends on the type of script. Perhaps a systemd unit file or /etc/xdg/autostart folder.

Made the script executable?

Did you try if it works as per https://www.whonix.org/wiki/About#Based_on_Debian on plain Debian [jessie]?

For those stumbling upon the same problem:
The solution was to rmb on the script>properties>permissions>mark:"is executable"
Then after system en settings>startup and shutdown>autostart>"having added the script"
click in the overview shown, and mark “is executable” again.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]