[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

apt gets 403 Forbidden

in a fresh install i am running whonixcheck:


[WARNING] [whonixcheck] Debian Package Update Check Result: Could not check for software updates! (apt-get code: 100)
Please manually check:
(Open a terminal, Start Menu -> Applications -> System -> Terminal.)
sudo apt-get-update-plus dist-upgrade

so thats what i do


Err:3 hxxps://deb.whonix.org stretch/main amd64 Packages
403 Forbidden

W: The repository ‘hxxps://deb.whonix.org stretch Release’ does not have a Release file.
E: Failed to fetch hxxps://deb.whonix.org/dists/stretch/main/binary-amd64/Packages 403 Forbidden
E: Some index files failed to download. They have been ignored, or old ones used instead.

I would like to have my gateway running passing the whonixcheck before even starting the workstation

I was having a somewhat similar issue all day yesterday. Trying to run the usual update commands resulted always in E: Some index files failed to download. They have been ignored, or old ones used instead. It seemed to be unable to connect to the servers. Like in your case it always got me 403’s or something along those lines.

Today I tried it again and ran a dist-upgrade. It finally updated some packages. After that I was able to do a simple update as well. (or the other way around, I can’t remember anymore). However running the suggested sudo apt-get-update-plus dist-upgrade does still not work as expected.

I’m wondering if this is related to the new v15 branch of Whonix?

Whonix repos for 15 and 14 down (clearnet & onion):

E: The repository 'https://deb.whonix.org stretch-testers Release' does no longer have a Release file.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

cc @Patrick

Server configuration issue. Too strict file permissions. Fixed.

1 Like