[HOME] [DOWNLOAD] [DOCS] [BLOG] [SUPPORT] [TIPS] [ISSUES] [Priority Support]

Anonymous Online With Kali linux + Whonix Gateway + VirtualBox


#1

i have found a great cool channel called Poison Attack which is teaching how to bind kali linux communications with Tor networks through whonix gateway. here r some videos:-

1- Anonymous Online With Kali linux 2.0 + Whonix Gateway

2- Stay anonymous online with Kali linux + Whonix Gateway (OLD)

and much more from whonix gateway + X os , check here:-

(his name is also patrick , i wonder if our patrick has a twine brother witha same name :D)


How to configure correctly the Whonix + Kali network
(Error) Installing Kali Linux with Whonix
#2

I use long time before whonix gateway with parrotsec. works perfectly. i don´t like the u/s kali.

townsend


#3

about the ddos tool xerxes. yes it is nice and i often do a test… smiling… / the only i don#t like is to search for the source… now find… http://pastebin.com/9HUsBWCu - hey guys please only for testing your own server…:wink:

townsend


#4

do u use DOS with Tor ? because Tor has a unique defending of DOS from its circuits.


#5

I’m struggling with the install…

I followed the video, but when i reach the part where i select to install, ie graphic install, after i click that the screen goes black and doesnt do anything.

Im running Debian Version 7.9
I’m using Virtualbox version 4.1.42_debian r103435
Kali Version 2016.1 32 Bit

Any pointers?


#6

did u enabled PAE/NX for kali linux since u r using 32-bit ?


#7

Hey mate…

Yeah i enabled it, tried a few more times with same result sigh


#8

Which one would be “regarded” as safer to use in conjunction with Whonix Gateway? Kali or just the Whonix Workstation?

In terms of anonymity etc


#9

Whonix-Workstation


#10

Still no fix. Managed to work out why 64 bit wasn’t working, i hadn’t enabled virtualisation in BIOS.

I am ashamed to say ive given up. Cant get past the same stage everytime, click on graphic install and screen goes blank, no writing, no prompt nothing.

I’ve watched so many videos and trolled so many sites and cant find a fix. If anyone can help i’d appreciate it


#11
  1. search terms: “install kali” virtualbox “black screen”
  2. try “Install”, not “Grahical Install”
  3. research “nomodeset” kernel parameter

#12

Hey Entropy…

Well, my ‘i give up’ lasted 3 hours…Came back to it (hate being beat), and tried all your suggestions, no luck…

BUT!

I hit page 13 on a search term, and 1 lonely little post solved it all.

Under System in Virtualbox, i clicked Acceleration, and unchecked ‘enable nested paging’.

Retried it, and away i go!!. Doing all updates and upgrades in source list atm…

Thanks again Entropy, as always, your help is appreciated


#13

CPU with VT-x + EPT is required for nested paging (most post-Sandy Bridge processors)

Strange that Kali would give you an issue if Whonix didn’t (both are Debian based).

Congratulations in any case, making it to pg 13 of a search is some persistence.


#14

Is this something covered in documentation already?

Can we add that here?


#15
  1. Can’t confirm that the solution has isolated the cause.
  2. Not sure how a Whonix VM would react to enabled nested paging with a non-EPT cpu. Maybe Kali-specific? (Would have to dig up an old Core 2 to test)

@Tenacity2016 You tried changing many things. Are you sure that ‘enable nested paging’ was the one, isolated variable that allowed Kali to boot? If you’re comfortable saying, what model cpu are you using? Could you try booting a Whonix VM with nested paging enabled?

This 5 year old post says VBox won’t allow enabling nested paging on non-supported cpus: http://superuser.com/a/286947


#16

Hey…

God your right i did change so many things, so i appreciate im not making life easy for you’s.

To be honest, i’m a little wet behind the ears (as you know) so i cant really pinpoint exactly what i did, saying that though, i didn’t stray too far from instructions.

I just double checked and yes 100%.


#17

Sorry for double posting…

I’ll check cpu later and update, i;ll pm it though if you dont’ mind?


#18

ive emailed the details.


#19

i made blah blah blah. UDP and TCP, iam happy tonight. Sorry…


#20

Would following the steps in the first video prevent my ISP from knowing I’m using TOR? Or would I need a VPN on the host?