[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Android Workstation can't connect

Hello! I use the Whonix Gateway without Qubes, and it works perfectly using a Linux or Windows Workstation.

Since using an Android emulator inside a Windows VM is awful (I’ve tried a lot of solutions, but it’s unstable and crash at some points), I’m trying to use an Android VM as a Workstation, by attaching it to the Gateway.

On Adapter 1 of the Workstation I have an Internal Network with Whonix name, the Intel PRO/1000 MT Desktop (82540EM) Adapter, Deny on Promiscuous Mode and Cable Connected check, the same settings as for Linux or Windows I guess.

I load the Gateway first, then I start the Android Workstation, and I can’t obtaining an IP adress. I’ve read the note about Android Workstation on docs, but I don’t see any eth0 in console mode, and my knowledges are very limited, I’m lost!

There is a solution? Perhaps a firewall setting from the Gateway? Or something dumb I’ve forgotten, also I don’t have tried the very last version of Whonix. Thank you!

How do you emulate Android in the Workstation? With Anbox I guess?

Anyway have you tried running these commands in a console in Anbox (source: https://www.whonix.org/wiki/Other_Operating_Systems):

su
ifconfig eth0 10.152.152.12 netmask 255.255.192.0
ip rule add from all lookup main pref 0
busybox route add default gw 10.152.152.10
ndc resolver setnetdns 100 localdomain 10.152.152.10

I tried them myself several months ago and they worked. But still quite unstable…

1 Like

Anbox doesn’t work on Windows, but I’ve tried it on Linux. I’ve tried MeMu and Bluestacks. But Nested Virtualisation is unstable sadly.

Well, I don’t have any eth0 network on my Android VM, but perhaps I forgot something!

But what did you use in this particular case, on Whonix-Workstation? These commands only worked with Anbox, as far as I know.

1 Like

Android x86, Bliss OS and such, as Workstation.

You mean thse commands only work on an Anbox console inside a Linux Workstation?

Saw recently updated chapter https://www.whonix.org/wiki/Nested_Virtualization#VirtualBox_inside_VirtualBox ? It addresses some stability issues.

I will do some more tests, even if my settings was ok. Thank you for your answers already :slight_smile:

It why I was looking for an ‘easier’ solution, using Android x86 or similar, than running an emulator (so an VM) inside a VM!

I mean they were tested on Anbox installed in a Whonix-Workstation (or another Linux distribution connected to a Whonix-Gateway). They may work in another setting, but it is untested.

Might be worth adding that in the Wiki.

It’s why they doesn’t work on Android x86, thank you!

I will try again using Anbox, with the newest version, since I’ve used an old snap I think.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]