[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

Am I using ARM correctly?

When I tried arm for the first time, it gave me a warning that connections could not be monitored and to add “DisableDebuggerAttachment 0” if I wanted to correct this. So I did.

After I restarted arm, it then said I had to run arm as the same user running tor so I’ve since been running arm with “sudo -u debian-tor arm”.

Is this all ok or should I put everything back to default? I also get warnings saying there are unrecognized categories in the man page (GENERAL OPTIONS and COMMAND-LINE OPTIONS). I assume this is a known issue?

Thanks

Hi, good question. Documentation should be added for this.
All fine on your side. No changes to arm required.
There are a few minor bugs in arm which cause confusion.
New documentation to answer these has just been added minutes ago due to your question :):

Patrick, I have had the gateway running by itself for awhile now and would like some clarification on a couple warning messages I’ve received.

First, I’ve seen this the most:

[WARN] Socks version 71 not recognized. (Tor is not an http proxy.)

A few seconds later, but not always, it is often followed by a “new control connection opened” message. Is this just a connected node sending a request my gateway doesn’t like? If I wanted to investigate this further, for my own knowledge building, where would I look on my gateway?

However, while typing this, I just noticed another, more interesting warning, pop up:

[WARN] Rejecting SOCKS request for anonymous connection to private address [scrubbed].

Again, where could I look to investigate this? Many thanks.

Just added some more information to answer this.

Please tell me if this leaves open questions.

Only in respect to the second question as I was not, knowingly, using curl at the time. I had just finished installing -workstation, updating it, and installing Tor for the first time. I had just finished logging into the forums and was typing my post when I glanced over and saw the message pop up on arm. Nothing else, to my knowledge, was going on on the workstation at this time. However, the message has not returned since either.

[WARN] Rejecting request for anonymous connection to private address [scrubbed] on a TransPort or NATDPort.
My message didn't make any type of port reference, the exact wording was:

" [WARN] Rejecting request for anonymous connection to private address [scrubbed]."

Not just curl, but any applications configured to use stream isolation by default and attempting to access local IPs.

Not sure. Not a big problem either way.

Eventually whonixcheck attempted to access the local port before rinetd started. WIll be maybe fixed in second Whonix 9 testers-only version and above.

Hi, I don’t know if posting here is the best choice, but I noticed that Arm (GUI) does not refresh circuits automatically. I have to close and re-open it to see new or changed circuits. I launch it from desktop icon and I didn’t change the DisableDebuggerAttachment option. Should I?

I don’t understand that question. Just mailed the maintainer of arm on where to best post the question. Damian Johnson prefers questions posted on the tor-talk mailing list, so others can benefit from the answer, but private e-mail questions are also okay.

About DisableDebuggerAttachment see also:

Thanks, I’ll try there. If I get some new info I’ll post them here too…

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]