[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

After last apt-get upgrade Gateway doesn't connect to tor anymore

There is a temporary workaround, that might work:

It’s untested, because I am still unable to reproduce the issue.

Please check if it works for you.

Anyhow, it would be very nice if you could help solving this issue! Checking if the files I mentioned above differ on your system would help a lot!

I checked the files and they seem to be exactly the same.

Even more strange why it doesn’t work for you but for me. We really should sort this out.

Are you using some kind of pluggable transports, obfsproxy?

The work-around works.

no proxy here.

Actually, I have a VPN running on this PC. It starts and connects with windows. Never had any problem with 8.2. Do you think that could be it?

Yeah, i’m starting to think to this too… I’m using debian here not windows, but I got a vpn who starts with pc too.

[quote=“TurtleMan, post:24, topic:532”]The work-around works.

no proxy here.[/quote]

Works for me too now. But I don’t get it what I’ve done since i’m not an expert… is my security lower now?

VPN is probably unrelated.

Same would probably happen with Whonix 8.2 as soon as you dist-upgrade. Can you test please?

Disabled Tor using AppArmor (https://en.wikipedia.org/wiki/AppArmor).

Yes. Back to Debian default.

Tested 8.2 and had no problems. I’m not sure what the cause would be.

I have also received this error after the last apt-upgrade, I’m using a fresh Whonix 9 and no proxy or VPN. The apt log shows the same message as TurtleMan’s screenshot:

profile system_tor: has merged rule /usr/bin/obfsproxy with conflicting x modifiers ERROR merging rules for profile system_tor, failed to load

[s]Here is another workaround. Won’t work for obfsproxy users - but could help leaving AppArmor for Tor enabled. And would help figuring out why this is happening.

  1. Undo https://www.whonix.org/wiki/Download#Connection_Issues_-_Tor_stops_working_after_an_Upgrade_and_needs_a_Workaround if you applied it.

  2. Backup /etc/apparmor.d/local/system_tor

sudo cp /etc/apparmor.d/local/system_tor /etc/apparmor.d/local/system_tor.backup

  1. Replace /etc/apparmor.d/system_tor with the default version

sudo cp /etc/apparmor.d/local/system_tor.anondist-orig /etc/apparmor.d/local/system_tor

  1. Restart Tor

sudo service tor restart

  1. See if it worked and report back.
    [/s]

With that (https://www.whonix.org/forum/index.php/topic,559.msg4311.html#msg4311) workaround in place, I am no longer getting the “ERROR merging rules for profile system_tor, failed to load” error. So I find it likely, it may work for you.

Even better workaround… In file

Commenting out “/usr/bin/obfsproxy rix,” is sufficient.

I.e. replace.

with

Safe. Then restart Tor.

Should likely work. Please test!

Wondering why this is happening.

It’s happening because in file

with the last update of the Tor package, the line.

has been added.

(So the workaround https://www.whonix.org/forum/index.php/topic,559.msg4313.html#msg4313 actually should work for everyone.)

Commenting out that line was successful, my Gateway has Tor running now.

Starting the service with “sudo service tor restart” did not work for me though, I received a message that “system_tor” did not exist. Rebooting seems to have fixed the issue, Tor started up normally.

Same problem here.

I have tried the workaround, but I can’t save the edit.

Can someone tell me how I go about saving the file as root, if that is what I need to do (noob question, I know!)

Thanks!

Me again.

No need for noob help on saving file as root. Discovered “sudo nano”.

Tor now working. And I learned something new about using the terminal!

[quote=“rook, post:35, topic:532”]Commenting out that line was successful, my Gateway has Tor running now.

Starting the service with “sudo service tor restart” did not work for me though, I received a message that “system_tor” did not exist. Rebooting seems to have fixed the issue, Tor started up normally.[/quote]

Worked for me too, sudo service tor restart didn’t worked, had to reboot too

Dear Patrick.

I had the same Problem on a new install, but fixed with outcommenting. Thank you very much for the Fix!

Best Regards!

townsend

I commented out the line and it all works now.

[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]