[HOME] [DOWNLOAD] [DOCS] [NEWS] [SUPPORT] [TIPS] [ISSUES] [DONATE]

A Call to action for Heroes! *Gave up waiting for root device*

Salutations,
Im incredibly new to Virtualbox as well as linux, and I ran into a problem on my Whonix Workstation, which is as follows:

Forgive me, I’ve tried my best at trying to solve the problem on my own, I’ve delved into the fiery pits of Hades with a stomach full of Grit and Anger. But my feeble attempts were in vain.
I cant reinstall it either because I have sensitive information on it.

Appreciate all the help I can get, guys. Thank you.

Good day,

Did you by any chance change anything related to the USB or input settings regarding your workstation?

Have a nice day,

Ego

1 Like

Not that I can recall, I updated Workstation closed the computer then the next day I ran into this problem.

Wait, Though I did connect a Usb hub the day after which Is currently plugged in.

Still the same problem with no usb devices connected.

Any other suggestions?

Got any other tips mate? Will be forever in your debt if you can help me.

Your best bet is read vbox images directly on the host and salvage your important data. I can’t remember the package name off the top of my head but a quick search will help you. Lookup the tool manual page to know how to use it.

PS If this helps you please consider donating any spare cash to the project to help further development.

1 Like

Which version of Whonix? Could be either something with the initramfs, grub or the hard disk got missing. Post output of blkid in the initramfs and if it finds something try to mount the disk manually and take a look at /boot/grub.cfg and/or regenerate the initramfs from within a chroot.

This is my first time using the program and Im not that good with the jargon, could you please help explain step by step?
Thank you.

“Post output of blkid in the initramfs and if it finds something try to mount the disk manually and take a look at /boot/grub.cfg and/or regenerate the initramfs from within a chroot.”

This is what is confusing me, would be thankful if you can reply as soon as possible, and of course I will donate if it helps, the most important thing is my gpg4usb installation because there is the only place where I can access my private key.

Thank you.

When you get dropped to the initramfs shell enter:

blkid

then press enter. In case there is no output the disk is missing for whatever reason.
If blkid finds the disk you can try to mount it manually via:

mount -t ext4 -o rw /dev/sda1 /root

to view grub do

cat /root/boot/grub/grub.cfg | less

to regenerate the initramfs do

chroot /root
update-initramfs -u -k all
exit
umount /root

Reboot machine.
Not sure if it will help. Backup the machine before doing anything. Still the approach by HulaHoop is probably easier. Alternatively you could attach some live cd to the VM, boot from the CD and then mount the image from the running VM. Or attach the disk of the non working VM to a VM which works and mount it from there.

2 Likes

If this is working, please add to the wiki. Very useful to have.

Hi, were you able to solve your problem? If not, you should probably backup your data and then just delete the VMs and setup new ones. To backup your data, you can try to follow these steps:

1. Make a backup of your Workstation disk
In case anything goes wrong, it is better to do a backup copy of your Workstation disk before attempting to backup your data.
In VirtualBox, make a right click on the Workstation VM, and chose “show in File Manager”. This will open the folder where your Workstation VM is. Make a copy of the “.vmdk” file.

2. Set up a new, separate Linux VM with shared folder
In VirtualBox, create a new Linux VM, Ubuntu for example. Install Linux guest additions to enable shared folders.

3. Create a shared folder
In VirtualBox, create or use a folder on the host to serve as a shared folder.

vm1

4. Add the Workstation disk to your Linux VM
In VirtualBox, add the Workstation disk to your new Linux VM

vm3

5. Copy the the data in the shared folder
Fire up the new Linux VM, access your Workstation disk and copy the files you want to save into the shared folder

What’s the point of a Ubuntu VM? How would the user get his data back into another Whonix VM?

We also need to find the root cause of this issue, prevent it, as well as figure out how to fix the issue after it happened.

Patrick, sorry if my answer seemed out of topic or confusing, BajsDanne was worried about his data in the Workstation and I just wanted to share a method I knew of of how to retrieve the data. Once the data is retrieved on the host, it could be easily copied into a new Workstation through a shared folder. I reckon there might be easier ways to access data inside a VBox disk image that I just don’t know of.

Of course, it doesn’t address the root cause of this problem that still needs to be fixed.

1 Like
[Imprint] [Privacy Policy] [Cookie Policy] [Terms of Use] [E-Sign Consent] [DMCA] [Investors] [Priority Support] [Professional Support]